Bug 137122 - Unable to mkfs with GUI
Unable to mkfs with GUI
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-10-25 17:29 EDT by Derek Anderson
Modified: 2009-04-16 19:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-04 07:40:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2004-10-25 17:29:12 EDT
Description of problem:
Create a VG, go to the Logical View and initiate "Create New Logical
Volume".  Fill out name and size.  For "Filesystem:" select ext2. 
Click "OK".  After refresh you have "No Volume Selected".

Navigate the tree to the Logical view of that VG.  The LV you asked to
have created is there.  Now go to the command line and attempt to
mount the filesystem on that LV:

[root@link-12 root]# mount -t ext2 /dev/ddd/MyFS /data1
mount: wrong fs type, bad option, bad superblock on /dev/ddd/MyFS,
       or too many mounted file systems

Syslog says:
VFS: Can't find ext2 filesystem on dev dm-0.

=======================
You can manually make and then mount a filesystem on this LV:

[root@link-12 root]# mkfs -t ext2 /dev/ddd/MyFS
mke2fs 1.35 (28-Feb-2004)
Filesystem label=
OS type: Linux
Block size=1024 (log=0)
Fragment size=1024 (log=0)
25688 inodes, 102400 blocks
5120 blocks (5.00%) reserved for the super user
First data block=1
13 block groups
8192 blocks per group, 8192 fragments per group
1976 inodes per group
Superblock backups stored on blocks:
        8193, 24577, 40961, 57345, 73729

Writing inode tables: done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 23 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
[root@link-12 root]# mount -t ext2 /dev/ddd/MyFS /data1
[root@link-12 root]# echo $?
0


Version-Release number of selected component (if applicable):
system-config-lvm-0.9.1-2.5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kiersten (Kerri) Anderson 2004-11-12 09:49:26 EST
Need an update on status on this one.  It is on the blocker list for
RHEL4 RC or more appropriately, the inclusion of this package in the
release.
Comment 2 Jim Parsons 2004-11-15 17:02:26 EST
This is fixed in 0.9.10-1.0. Unfortunately, only ext2 and ext3 are
available as choices, due to a bug discovered in device mapper. Bug is
entered as #139420
Comment 3 Derek Anderson 2004-11-17 12:45:39 EST
I selected to create an ext2 fileystem and did not specify a mount
point.  The filesystem was created properly, but then I got this
traceback:

Traceback (most recent call last):
  File "/usr/share/system-config-lvm/InputController.py", line 795, in
on_ok_new_lv_button
    self.command_handler.new_lv(new_lv_command_set)
  File "/usr/share/system-config-lvm/CommandHandler.py", line 81, in
new_lv
    command = "mount " + lvpath + " " + mnt_point
UnboundLocalError: local variable 'mnt_point' referenced before assignment

Checked against version 0.9.11-1.0.
Comment 4 Jim Parsons 2004-11-17 18:24:23 EST
indentation error - python is so picky about such things. Fixed in
0.9.12-1.0
Comment 5 Derek Anderson 2004-11-19 16:21:49 EST
Verified in system-config-lvm-0.9.12-1.0.
Comment 8 Jay Turner 2004-12-04 07:40:52 EST
system-config-lvm-0.9.18-1.0 is included in re1201.0.  Closing out.

Note You need to log in before you can comment on or make changes to this bug.