Bug 1371276 - [RFE] Do not do a mirror on sync when using incremental content
Summary: [RFE] Do not do a mirror on sync when using incremental content
Keywords:
Status: CLOSED DUPLICATE of bug 1416888
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.2.0
Hardware: s390
OS: Unspecified
low
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-29 18:29 UTC by Ash Westbrook
Modified: 2019-08-12 16:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-11 18:38:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 22012 None None None 2017-12-18 15:25:30 UTC

Description Ash Westbrook 2016-08-29 18:29:21 UTC
Document URL: 

https://access.redhat.com/documentation/en/red-hat-satellite/6.2/single/content-management-guide/


Section Number and Name: 

Section: C 6.3

Mirror on sync defined:
Repositories now have the option to be used in a “mirror on sync” state where the state of the repository mirrors that of the upstream repository at sync time. This results in packages no longer in the upstream repository being removed.  mirror-on-sync is set to true by default.  

Describe the issue: 

It assumes that you want it to remove old/broken packages when you update from the source.  The "fix" is to disable it when creating the repo:

hammer repository create \
  --name='testrepo1' \
  --organization-id=1 \
  --product='product1' \
  --content-type='yum' \
  --publish-via-http=false \
  --mirror-on-sync=false \
  --download-policy=immediate


Suggestions for improvement: 

It should not do a mirror on sync when using incremental.

Additional information:

Comment 2 Andrew Dahms 2016-11-14 00:09:24 UTC
Moving to engineering based on case comments.

Feel free to move this back to documentation if this is the intended behavior and guidance should be provided in the documentation instead.

Comment 5 Andrew Dahms 2017-12-05 13:17:03 UTC
Assigning to Clifton for review.

Comment 9 Justin Sherrill 2017-12-18 15:25:27 UTC
Created redmine issue http://projects.theforeman.org/issues/22012 from this bug

Comment 10 Justin Sherrill 2017-12-18 15:28:32 UTC
I've cloned this upstream to do the work to prevent it from happening.  Moving back to NEW

Comment 14 Bryan Kearney 2018-01-11 18:38:22 UTC

*** This bug has been marked as a duplicate of bug 1416888 ***


Note You need to log in before you can comment on or make changes to this bug.