Bug 137138 - [Patch] java crashes because of execute disable mapping of data
[Patch] java crashes because of execute disable mapping of data
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 20:52 EDT by Suresh Siddha
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 17:01:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposal for a fix (583 bytes, patch)
2004-10-25 20:54 EDT, Suresh Siddha
no flags Details | Diff

  None (edit)
Description Suresh Siddha 2004-10-25 20:52:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
For a legacy binary(which doesn't have PT_GNU_STACK program header 
and assumes READ implies EXEC behaviour), kernel is mapping data 
segment as not executable. Because of this issue java doesn't run  on 
a processor which supports 'execute disable' feature

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.EL

How reproducible:
Always

Steps to Reproduce:
1.Boot the x86 kernel on a processor which supports exec disable 
feature
2.Run java. It hangs with recursive seg faults.
3.
    

Additional info:
Comment 1 Suresh Siddha 2004-10-25 20:54:44 EDT
Created attachment 105764 [details]
Proposal for a fix

2.6 kernels have solved this issue by using READ_IMPLIES_EXEC personality.
Comment 2 Ernie Petrides 2004-12-15 17:01:52 EST
This problem was resolved in the RHEL3 U4 kernel on 1-Dec-2004
(in kernel version 2.4.21-27.EL).

*** This bug has been marked as a duplicate of 137464 ***
Comment 4 John Flanagan 2004-12-20 15:56:48 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.