Bug 137151 - [firstboot] missing translation for firstboot contents
[firstboot] missing translation for firstboot contents
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
David Lawrence
:
: 138315 (view as bug list)
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-10-26 04:49 EDT by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 04:33:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
untranslated text start from this section (88.61 KB, image/png)
2004-10-26 04:53 EDT, Lawrence Lim
no flags Details
message prompt is not translated as well (108.64 KB, image/png)
2004-10-26 04:53 EDT, Lawrence Lim
no flags Details
the following section (86.65 KB, image/png)
2004-10-26 04:54 EDT, Lawrence Lim
no flags Details
anf the next.. (82.06 KB, image/png)
2004-10-26 04:55 EDT, Lawrence Lim
no flags Details
final section (95.18 KB, image/png)
2004-10-26 04:55 EDT, Lawrence Lim
no flags Details
screenshot of firstboot iin the ja_JP locale (146.74 KB, image/png)
2004-11-15 04:23 EST, Lawrence Lim
no flags Details
screenshot of firstboot in the de locale (115.81 KB, image/png)
2004-11-15 19:28 EST, Lawrence Lim
no flags Details
firstboot in the es (spanish) locale (109.21 KB, image/png)
2004-11-15 19:53 EST, Lawrence Lim
no flags Details
firstboot in the fr (french) locale (109.47 KB, image/png)
2004-11-15 19:54 EST, Lawrence Lim
no flags Details
screenshot of firstboot in the it (italian) locale (104.28 KB, image/png)
2004-11-15 19:56 EST, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2004-10-26 04:49:45 EDT
Description of problem:
It has been observed that the last few section of firstboot, starting
from creating new user till the end are not translated.

Version-Release number of selected component (if applicable):
firstboot-1.3.30-1

How reproducible:
Always

Steps to Reproduce:
1.LANG=ko_KR.UTF-8 firstboot
2.
3.
  
Actual results:
The content of firstboot in the last few section are still
untranslated. Please see attached screenshots.

Expected results:
Should be translated to the languages supported by RHEL

Additional info:
Comment 1 Lawrence Lim 2004-10-26 04:53:01 EDT
Created attachment 105781 [details]
untranslated text start from this section
Comment 2 Lawrence Lim 2004-10-26 04:53:48 EDT
Created attachment 105782 [details]
message prompt is not translated as well
Comment 3 Lawrence Lim 2004-10-26 04:54:46 EDT
Created attachment 105783 [details]
the following section
Comment 4 Lawrence Lim 2004-10-26 04:55:22 EDT
Created attachment 105784 [details]
anf the next..
Comment 5 Lawrence Lim 2004-10-26 04:55:51 EDT
Created attachment 105785 [details]
final section
Comment 8 Leon Ho 2004-10-31 20:58:28 EST
Thanks to Adrian. Should have firstboot with latest translation in
dist-4E-HEAD.
Comment 9 Lawrence Lim 2004-11-08 02:16:11 EST
I did a check on 1.3-34.1 and the bug still exist. Assigning back to
Adrain.


Comment 10 Lawrence Lim 2004-11-08 02:40:14 EST
*** Bug 138315 has been marked as a duplicate of this bug. ***
Comment 13 Lawrence Lim 2004-11-09 22:58:48 EST
Confirmed all 14 locales supported by RHEL are still experencing the
same problem in dist-4E-HEAD.
Comment 14 Adrian Likins 2004-11-10 12:37:42 EST
I'm a little stumped as to why the translations are
showing up correctly, everything looks correct. I
suspect it's related to the modules having a different
text domain than the main app... trying to
figure out how to rectify that at the moment.
Comment 15 Adrian Likins 2004-11-10 16:47:41 EST
figured it out, new packages on the way,
ran though de/ja/ru and a few others and
everything looks to be translated
Comment 16 Adrian Likins 2004-11-10 17:21:57 EST
up2date-4.3.57 and firstboot-1.3.35 should make everything work
correctly.
Comment 17 Adrian Likins 2004-11-11 16:28:38 EST
correction, that is not the case... 
up2date-4.3.57 installs translations into /share/locale
because of a Makefile bug... 

4.3.60 might have a fix
Comment 18 Lawrence Lim 2004-11-15 03:39:10 EST
Tested firstboot-1.3.37-2 and up2date-4.3.61-2. Most of the translation has been
incorporated. There are however, some strings in the indic locale that are not
translated. Sarah, if you can please help a look, that will be great. :)

I have did msgunfmt for these locale.

bn_IN
"License Agreement" not translated
"Red Hat Login" entry not available in firstboot.po

gu_IN
"License Agreement" not translated
"Time and Date" not translated

hi_IN
"License Agreement" not translated

pa_IN
"License Agreement" not translated

ta_IN
"License Agreement" not translated
"Time and Date" not translated

Comment 19 Lawrence Lim 2004-11-15 04:01:14 EST
I have a question. Is the Privacy Statment going to be translated? I noticed all
supported locale are not.
Comment 20 Lawrence Lim 2004-11-15 04:23:34 EST
Created attachment 106700 [details]
screenshot of firstboot iin the ja_JP locale

I noticed that some of the characters with parenthesis are missing and please
note the string near the check box. It is completely missing.
Comment 21 Lawrence Lim 2004-11-15 19:28:52 EST
Created attachment 106774 [details]
screenshot of firstboot in the de locale

Information towards the bottom of the screen is not readable.
Comment 22 Lawrence Lim 2004-11-15 19:53:05 EST
Created attachment 106775 [details]
firstboot in the es (spanish) locale

Notice the infomration found towards the bottom of the page is unreadable.
Comment 23 Lawrence Lim 2004-11-15 19:54:57 EST
Created attachment 106776 [details]
firstboot in the fr (french) locale

Notice that the information found towards the bottom of the page is not
readable.
Comment 24 Lawrence Lim 2004-11-15 19:56:12 EST
Created attachment 106777 [details]
screenshot of firstboot in the it (italian) locale

Notice the information found towards the bottom of the page is not readable.
Comment 25 Leon Ho 2004-11-16 06:32:56 EST
Filed the RHN registration problem on bug 139495.

If everything is translated on firstboot in a sensible way then let's
close this bug.
Comment 26 Jay Turner 2004-11-26 08:46:39 EST
With firstboot-1.1.27-1, I'm still seeing some strings which aren't translated
and I think should be:

ja_JP:
"System User" in the left-hand bar throughout
All of the text on the welcome screen, with the exception of the header
Heading and intro text on the System User screen
The last line on the "Finished" screen

zh_CN:
All of the above
"Login" on the initial RHN reg screen

zh_TW:
Same as zh_CN
Initial text and "Extras" on screen prompting for additional CDs

So, basically looks like we need to go through these one-by-one and make sure
that we're as complete as possible.  The weird thing is that according to the
counts above, it seems that the translated strings are there, so not really sure
why they aren't getting picked up.

Bouncing back to assigned in order to get this straight.
Comment 27 Jay Turner 2004-12-03 03:43:43 EST
One of the i18n guys . . . is the above described behavior OK with you for U4? 
Need to know something pretty quickly, as we're trying to put the final nails in
the U4 coffin.
Comment 29 Leon Ho 2004-12-03 04:25:13 EST
The real reason is because RHEL3 translations is in the branch,
localization team has no way to know there are po updates in that
particular branch.

i.e. 
$ cvs up -r firstboot-taroon
$ msgfmt -o /dev/null -v ja.po
ja.po
62 translated messages, 3 fuzzy translations, 2 untranslated messages.

#: ../src/modules/create_user.py:42
msgid "System User"
msgstr ""


Comment 30 Sarah Wang 2004-12-07 01:25:22 EST
12 out 14 supported languages have updated RHEL3 branch po files.
Spanish and Tamil can't be done in time because we don't have the
resource at the moment. Please consider rebuild.

Sarah
Comment 31 Michael Hideo 2004-12-07 21:22:44 EST
Having firstboot completely translated in Spanish would probably be a
good thing. my understanding is that this will be complete COB Friday,
10 Dec Australian EST.
Comment 35 Sarah Wang 2004-12-09 22:34:48 EST
Spanish is done. As RHEL3 doesn't support Indic languages yet, I guess
missing Tamil translation shouldn't be a big concern.

Sarah
Comment 36 Jay Turner 2004-12-10 04:33:57 EST
All of the translations that I just spot-checked look really good with
firstboot-1.3.37-2.  We still have some missing translations with the firstboot
going out in RHEL3-U4 (comment 26 still applies) but this bug is blocking RHEL4,
so going to close it out.
Comment 37 John Flanagan 2004-12-21 15:45:37 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-581.html

Note You need to log in before you can comment on or make changes to this bug.