Bug 137184 - options command in modules.conf does not work with probeall
options command in modules.conf does not work with probeall
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: modutils (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-26 11:35 EDT by John DeFranco
Modified: 2014-03-16 22:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 23:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John DeFranco 2004-10-26 11:35:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514

Description of problem:
When using the bonding driver with options the following needs to be
added to the /etc/modules.conf file:

alias bond0 bonding
options bond0 miimon=100 mode=1

In this case we are trying to set mode 1 (active/backup).

This works fine except when other network drivers need to be loaded
first, in this case when using the probeall command in the
/etc/modules.conf file. For example if the modules.conf file looks like:

alias bond0 bonding
options bond0 miimon=100 mode=1
probeall bond0 eth0 eth1 eth2 eth3 bonding

With this sequence the options line for bond0 seems to be ignored and
default settings are used, in this case mode 0 (round robin mode),
which is not what I want.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create the proper ifcfg-bond0, ifcfg-ethX files to define bonding
and slave interfaces.
2. Add the above entries into the /etc/modules.conf file
3. reboot the system. Check the /proc/net/bonding/bond0 entry. Will show:

[root@tsg root]# cat /proc/net/bonding/bond0
bonding.c:v2.4.1 (September 15, 2003)

Bonding Mode: load balancing (round-robin)
MII Status: up
.
.
.

It should show 

[root@csg root]# cat /proc/net/bonding/bond0
bonding.c:v2.4.1 (September 15, 2003)

Bonding Mode: fault-tolerance (active-backup)
Currently Active Slave: eth3
.
.
.


    

Additional info:
Comment 1 Bill Nottingham 2004-10-26 12:11:23 EDT
What happens if you change it to:

options bonding ....
Comment 2 Bill Nottingham 2005-04-19 23:26:53 EDT
Closing, no response.
Comment 3 Tayde Molinar 2005-08-12 19:36:14 EDT
Hi,

I had the same problem and it was corrected with the "options bonding ..."

alias bond0 bonding
options bonding mode=1 miimon=100  
probeall bond0 eth0 eth2 bonding

Regards

Note You need to log in before you can comment on or make changes to this bug.