Bug 137215 - Webmin Users and Groups Button causes this
Summary: Webmin Users and Groups Button causes this
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL: https:/leopards.k12.ar.us:10000
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-26 18:48 UTC by Doug Simpson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-31 10:41:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Doug Simpson 2004-10-26 18:48:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:

Version-Release number of selected component (if applicable):
WebMin Version 1.160 on leopards.k12.ar.us (Redhat Linux Fedora 1)

How reproducible:
Always

Steps to Reproduce:
1.Install Webmin (actually tried versions from 1.110 through 1.160 on
the same and different servers with FC1, same error on all of them)
2.Click: "System" from the main WebMin screen.
3.Click: "Users and Groups" from the System menu in WebMin.
There is the output.

Actual Results:  I get the following output in the browser after
clicking the Users and Groups Button in WebMin:

HTTP/1.0 500 Perl execution failed Server: MiniServ/0.01 Date: Tue, 26
Oct 2004 18:41:13 GMT Content-type: text/html Connection: close
Error - Perl execution failed

panic: realloc at ./user-lib.pl line 932.

The line number listed above is slightly different with the different
versions of WebMin, but the error is the same.  I tried version from
1.110 through 1.160 on several FC1 servers with the same results.

Expected Results:  The browser should have displayed the user and
group management screen in WebMin.

Additional info:

I was told by another the following information:
                                                                     
          
WebMin is also broken in FC2 and FC3test3.  The bug is in glibc which
breaks PERL which breaks WebMin.  The bug occurs when there are more
than a few supplementary hundred members of a group.  The bug report is
here:
                                                                     
          
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=137199

Comment 1 Jakub Jelinek 2004-10-26 20:29:42 UTC
That is a perl bug, not glibc bug.

Comment 2 Warren Togami 2005-05-31 10:41:59 UTC
Sorry, we are unable to fix issues in FC1 perl.



Note You need to log in before you can comment on or make changes to this bug.