Bug 137227 - Patch diffs using PatchReader not displaying properly
Patch diffs using PatchReader not displaying properly
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Mike MacKenzie
Mike MacKenzie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-26 15:43 EDT by David Lawrence
Modified: 2007-04-18 13:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 12:16:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Command line perl script to test PatchReader (1.29 KB, text/plain)
2004-10-26 15:43 EDT, David Lawrence
no flags Details
Sample diff file for use with testpatchreader.pl (1.15 KB, text/plain)
2004-10-26 15:45 EDT, David Lawrence
no flags Details

  None (edit)
Description David Lawrence 2004-10-26 15:43:49 EDT
Description of problem:
When viewing a patch attachment as a diff, nothing is displaying properly 
between the header and footer. Other navigation links are displaying so the
proper actiion is being taken in attachment.cgi. It will work from the command
line if using a test perl script (attached).

Version-Release number of selected component (if applicable):
2.18 beta2
Comment 1 David Lawrence 2004-10-26 15:43:49 EDT
Created attachment 105811 [details]
Command line perl script to test PatchReader
Comment 2 David Lawrence 2004-10-26 15:45:07 EDT
Created attachment 105812 [details]
Sample diff file for use with testpatchreader.pl
Comment 3 David Lawrence 2004-10-26 15:45:43 EDT
URL to Main Bugzilla database showing what something like this should look like.

https://bugzilla.mozilla.org/attachment.cgi?id=163228&action=diff
Comment 4 Mike MacKenzie 2004-10-27 12:16:55 EDT
Okay this is fixed.  The problem was that the data being sent to the patch
reader was base64 encoded.
Comment 5 Hotmail Account 2004-10-27 12:20:37 EDT
Ah, right! now i feel stupid. Mucho Thanks.

Note You need to log in before you can comment on or make changes to this bug.