Bug 137231 - Extend Volume Group: need user confirmation before adding Unitialized Entity
Summary: Extend Volume Group: need user confirmation before adding Unitialized Entity
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact: Jim Parsons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 135876
TreeView+ depends on / blocked
 
Reported: 2004-10-26 20:27 UTC by Derek Anderson
Modified: 2009-04-16 23:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 16:12:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2004-10-26 20:27:56 UTC
Description of problem:
Create a VG and from the Physical View click "Extend Volume Group". 
From the list of disk entities to add select an "Uninitialized Disk
Entity" and click OK.  The disk is initialized and added to the VG.

Expect the:
Are you certain that you wish to initialize disk entity   /dev/sdf1?
All data will be lost on this device/partition.

Yes/No user confirmation before wiping a partition table.

Setting this as high priority simply because the #1 requirement as I
understand it is to make the user absolutely aware when they are about
to do something that may lose data.

Version-Release number of selected component (if applicable):
system-config-lvm-0.9.1-2.5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jim Parsons 2004-10-29 21:47:29 UTC
Fixed in 0.9.4-1.0

Comment 2 Derek Anderson 2004-11-04 16:12:31 UTC
Verified in system-config-lvm-0.9.6-1.0.


Note You need to log in before you can comment on or make changes to this bug.