Bug 137250 - gnome-vfs2 won't build cdda module due to libparanoia location
gnome-vfs2 won't build cdda module due to libparanoia location
Status: CLOSED DUPLICATE of bug 184061
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: 144803
  Show dependency treegraph
 
Reported: 2004-10-26 18:38 EDT by John Thacker
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-05 14:30:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Thacker 2004-10-26 18:38:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
gnome-vfs2-2.8.2-8
cdparanoia-devel-alpha9.8-24

gnome-vfs2 won't build its libcdda.so module, even though we have the
cdparanoia devel files installed.  This causes warnings and such.  It
isn't building because the autoconf script for gnome-vfs2 apparently
believes that the libraries should be in /usr/include/cdda_paranoia.h
and /usr/include/cdda_interface.h

However, the FC cdparanoia-devel packages have them in
/usr/include/cdda/cdda_paranoia.h and /usr/include/cdda/cdda_interface.h


Version-Release number of selected component (if applicable):
gnome-vfs2-2.8.2-8

How reproducible:
Always

Steps to Reproduce:
1.  Install gnome-vfs2-2.8.2-8, or rebuild it yourself
2.  Note the lack of /usr/lib/gnome-vfs-2.0/modules/libcdda.so
3.  Note the reference to the cdda module in 
    /etc/gnome-vfs-2.0/modules/default-modules.conf
4.  Run totem



Actual Results:  Error message:
(totem:2963): libgnomevfs-WARNING **: Cannot load module
`/usr/lib/gnome-vfs-2.0/modules/libcdda.so'
(/usr/lib/gnome-vfs-2.0/modules/libcdda.so: cannot open shared object
file: No such file or directory)

Expected Results:  No error message. 
/usr/lib/gnome-vfs-2.0/modules/libcdda.so should be built and installed

Additional info:

If the relevant include files are copied or linked to /usr/include,
then it all compiles and works fine.
It doesn't seem to actually break anything, mind you, just these
warnings.  If it's not going to be built, then the cdda module could
at least be commented out of
/etc/gnome-vfs-2.0/modules/default-modules.conf
as a module to use.
So this could either be a gnome-vfs2 issue or a cdparanoia-devel
issue, depending on how it should be handled.
Comment 1 Bastien Nocera 2004-11-11 18:13:56 EST
Still current for FC3, and it will create bazillions of warnings when
you add new files in Totem for example.
Comment 2 drago01 2004-11-28 01:54:06 EST
"It doesn't seem to actually break anything, mind you, just these
warnings."
It do. Totem is unable to play audio cds because of this.
Comment 3 John Thacker 2004-11-29 00:50:30 EST
You're right, you're right.  It won't play audio CDs because of this, at least
the FC3 version.  It seemed to work for me with a previous Rawhide version when
I made this bug, but the FC3 totem won't play audio CDs.  Maybe I had some
components from the xine version around.
Comment 4 John Thacker 2004-11-29 00:55:34 EST
Changing severity from low to normal since playing audio CDs doesn't work; it is
a major loss of function, but there are other ways to play audio CDs.  (Totem
does play audio CDs without the need for the audio cables attached though I
believe; are there as easy work arounds for that?)
Comment 5 John Thacker 2004-12-06 18:28:26 EST
So, there are three ways to get this to work:
1.  Patch the gnome-vfs2 sources so that it looks for the cdparanoia header
files in /usr/include/cdda
2.  Patch the gnome-vfs2 sources so that it works whether the cdparanoia header
fiels are in the RedHat location or in the "normal" location.  This would be a
little more annoying, but we could adapt what grip does to work around it.
3.  Put the cdparanoia headers back in /usr/include.  Note that we can
optionally not ship the "utils.h" header, since grip doesn't seem to need it
anymore.  In other words, bug #38223 is no long pertinent, so we should be free
to move it back.  I just tested compiling grip without utils.h present-- no
problems.
It would also be nice to fix 102754 as well.

Boy has it been far too long in between cdparanoia releases.
Comment 6 drago01 2005-02-09 07:25:53 EST
it can also be fixed be adding some links....
Comment 7 rodgerr 2005-02-21 00:19:01 EST
Isn't it about time that this product was repackaged and the bug got fixed?  I
like gnome, but I am tired of having to juice all my CDs to play them from the
Hard Drive.
Comment 8 Bastien Nocera 2005-05-10 17:37:00 EDT
If it's really hampering your usage of Totem, the quick fix is to run this as root:
perl -pi~ -e "s,cdda,#cdda," /etc/gnome-vfs-2.0/modules/default-modules.conf

Setting the priority to high, the fix is a recompile (or small patch) away.
Comment 9 Mephisto 2005-06-22 07:41:16 EDT
disabling the module wont help people play their cds. its been more than 1 month
after the last comment and still no solution? if its 'just a recompile', why not
do it now?
Comment 10 Frank Büttner 2005-08-10 14:38:25 EDT
When will it fix??
Comment 11 drago01 2005-09-18 07:44:59 EDT
any fix in for fc4?
or will we have to wait for fc5?
Comment 12 John Thacker 2006-02-24 14:53:22 EST
OK, this is ridiculous.  The cdda module doesn't need to be built, exactly, as
it's deprecated.  It ought to be at least commented out, though.

However, commenting it out *won't* fix totem. There's further totem weirdness. 
If I put an audio CD in the drive, totem plays it perfectly well with "totem
cdda://" no problem.  However, if I just launch totem, the "Play Audio Disc"
menu item is greyed out and unusable.  I added more information in bug 144803
Comment 13 John Thacker 2006-02-24 15:11:51 EST
OK, I think I'm convinced from looking elsewhere that totem not supporting
playing CDs in the GUI is intentional.  Don't know that I agree, but whatever. 
In any case, the cdda module still ought to be commented out to remove the
warning message.
Comment 14 John Thacker 2006-03-05 14:30:09 EST
Since the cdda module is deprecated upstream, I'm closing this bug and starting
a new one, bug 184061, with a more accurate description of the problem.  (I.e.,
the module should definitely just be commented out.)

*** This bug has been marked as a duplicate of 184061 ***

Note You need to log in before you can comment on or make changes to this bug.