Bug 137291 - "global name 'errorMessage' is not defined"
"global name 'errorMessage' is not defined"
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-10-27 06:25 EDT by Jay Turner
Modified: 2015-01-07 19:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 14:49:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2004-10-27 06:25:22 EDT
Description of problem:
Getting an error with system-config-lvm-0.9.3-1.0 when attempting to
remove a logical volume which is currently in use (in this case, / was
on the LV I was trying to remove.)  Looks like some more traps are
needed to notify the user they are attempting to remove an LV
currently in use, as well as "errorMessage" needs to be defined.

  Can't remove open logical volume "LogVol01"
Traceback (most recent call last):
  File "/usr/share/system-config-lvm/InputController.py", line 365, in
on_lv_rm
    errorMessage(e.getMessage())
NameError: global name 'errorMessage' is not defined


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jim Parsons 2004-10-29 17:54:43 EDT
This is actually two bugs - the 'global name errorMessage not defined'
is now fixed in 0.9.4-1.0, but the lv rm portion of this report still
needs looking into. Note to self!
Comment 3 Jim Parsons 2004-11-02 16:43:31 EST
This issue will be ready for QA on or before 11-05-04
Comment 4 Jim Parsons 2004-11-10 10:13:43 EST
Will be checked in today, 11-10-04  :-/
Comment 5 Jim Parsons 2004-11-12 10:41:51 EST
The errorMessage issue is fixed for this ticket, and now if you try
and remove an LV with a mounted filesystem on it, you are warned. Here
is an example warning message:

"BIG WARNING: Logical Volume /dev/adder/NewLV has an ext2 file system
on it and is currently mounted on /lv_test_mnt. Are you absolutely
certain that you wish to discard the data on this mounted filesystem?"
Comment 6 Jim Parsons 2004-11-12 10:42:36 EST
Oops: Forgot to say that this fix is in the upcoming 0.9.10-1.0 build
Comment 7 Derek Anderson 2004-11-17 14:49:24 EST
Verified in system-config-lvm-0.9.11-1.0.

Note You need to log in before you can comment on or make changes to this bug.