Bug 137292 - Clicking on an LV, then attempting to remove it doesn't work
Clicking on an LV, then attempting to remove it doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
: 137052 138839 (view as bug list)
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-10-27 06:44 EDT by Jay Turner
Modified: 2015-01-07 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 12:50:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2004-10-27 06:44:06 EDT
Description of problem:
Start up system-config-lvm-0.9.3-1.0, then click on the "Logical View"
which should show a graphic representation of the logical volumes. 
Now click on one of the LVs which make up the cylinder, then click the
 "Remove Selected Logical Volume(s)" button.  This will generate a
message along the lines of "Are you quite certain that you wish to
remove the Logical Volume LogVol00?" which is the first hint something
is wrong.  Answering "yes" results in a dialog stating that the
lvremove command failed and the command attempted was

/usr/sbin/lvremove --force LogVol00

But 'lvremove' is expecting the path to the LV, not just it's name, so
the call should actually be

/usr/sbin/lvremove --force /dev/VolGroup00/LogVol00

This works correctly if you click on one of the LV's first in the
left-hand pane.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jim Parsons 2004-11-09 23:52:58 EST
Doh, was not grabbing full path - even though the method was there to
use. 
Fixed @ 0.9.8-1.0
Comment 2 Derek Anderson 2004-11-11 10:24:57 EST
*** Bug 138839 has been marked as a duplicate of this bug. ***
Comment 3 Derek Anderson 2004-11-11 12:46:13 EST
*** Bug 137052 has been marked as a duplicate of this bug. ***
Comment 4 Derek Anderson 2004-11-11 12:50:20 EST
Verified in system-config-lvm-0.9.8-1.0.

Note You need to log in before you can comment on or make changes to this bug.