Bug 137315 - scheduling of 'Auto Errata Update' does not seem to be working for 'Update' entitlements
scheduling of 'Auto Errata Update' does not seem to be working for 'Update' e...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn360
All Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
Max Spevack
:
Depends On:
Blocks: 123188
  Show dependency treegraph
 
Reported: 2004-10-27 10:42 EDT by Clifford Perry
Modified: 2007-04-18 13:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:40:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clifford Perry 2004-10-27 10:42:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
A Red Hat client reported this issue on their RHN account. 

They have multiple systems registered to their account. Each system
has 'Update' entitlement, each system has 'Auto Errata Update' checked
and enabled, systems are shown to be checking in on a frequent basis -
so have rhnsd running. 
Almost all (but a small hand full that have had up2date ran manually)
have a red explanation mark next to them to show they have outstanding
errata to be applied to the systems. 

Checking on each system under Events and Pending Events I do not see
any pending events for the rhn_check command to pickup to apply the
outstanding errata. 

For 'Auto Errata Update' to work, we need to schedule an event for the
errata to be applied and then for the client system to pickup and
perform this scheduled event via the rhnsd and rhn_check command. 

It would seem that even though we list Auto Update of Errata as a
feature of 'update' entitlements online at:

http://www.redhat.com/software/rhn/table/
http://www.redhat.com/software/rhn/update/

is broken and not working. Briefly testing using Management and
Provisioning, they seem to be fine to me. 

To test and confirm this is working I would suggest to register system
with update entitlement, enable auto update, push errata and check to
see if it gets scheduled to be applied to system. 


Version-Release number of selected component (if applicable):
RHN Hosted 3.5.1

How reproducible:
Always

Steps to Reproduce:
Since I have not seen an errata released to RHN Hosted since this
issue was reported to me I cannot test and reproduce easily on our
live production web site but I believe this to be a bug and could be
reproduced. 

1. register system with update entitlement
2. enable auto update
3. push errata
4. check to see if errata gets scheduled as an event to be applied to
system

Additional info:

See private comment for rhn account in question.
Comment 2 Chip Turner 2004-11-04 15:51:08 EST
fixed, the UI functionality to require mgmt only is now in

test plan: go to the system detail page for an updates entitled
system, click 'Edit these properties'.  there should be a msg saying
that auto errata updates are not available.  unentitle the system
completely, ensure a message is present as well.  now entitle to
management, ensuring the checkbox is there.  entitle to provisioning
and ensire checkbox is there.
Comment 3 Max Spevack 2004-11-09 17:43:50 EST
Verified.
Comment 4 Todd Warner 2005-03-22 13:40:12 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.