This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 137348 - Totem crashes when playing aac file
Totem crashes when playing aac file
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
3
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-27 13:48 EDT by Michael A. Peters
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-31 18:44:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log file of crash (116.97 KB, text/plain)
2004-10-27 13:49 EDT, Michael A. Peters
no flags Details

  None (edit)
Description Michael A. Peters 2004-10-27 13:48:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
I built the faad2 plugin for gstreamer.

playing a .m4a file (encoded with iTunes) works from
gst-launch-ext-0.8 so I know the faad2 plugin works

When I launch totem and select a .m4a file, totem crashes.

log file from  totem > totem.log 2>&1

will be attached.



Version-Release number of selected component (if applicable):
totem-0.99.19-1

How reproducible:
Always

Steps to Reproduce:
1. launch totem
2. try to open a .m4a aac file
3.
    

Actual Results:  totem crashes

Expected Results:  totem plays the file

Additional info:

I am not asking for aac support in Fedora Core.
But totem should be able to play the file is support has been added to
gstreamer. gstreamer can play the file, so the bug seems to be with totem.
Comment 1 Michael A. Peters 2004-10-27 13:49:23 EDT
Created attachment 105852 [details]
log file of crash

This is log file mentioned in report
Comment 2 Michael A. Peters 2004-10-27 18:20:29 EDT
If I call the .m4a file from totem directly - the band and song name
correctly display in totem, it doesn't crash, but it doesn't play.

I can toggle the play and pause button, but it doesn't play. The time
bar remains greyed out.
Comment 3 Michael A. Peters 2004-10-27 21:27:24 EDT
If in nautilus I assign totem to be the player for files of type .m4a
- then select the file in nautilus and choose "open with totem" it works.

The progress bar zips through - but it works.

Weird that three different results happen with three different methods
of trying to play the file.
Comment 4 Michael A. Peters 2004-10-31 18:44:14 EST
It is now working perfectly in the scenarios where it did not before.
I do not know why, it wasn't an update to gstreamer or faad2 or totem
- but it's working now.

Note You need to log in before you can comment on or make changes to this bug.