Bug 137353 - Keyboard Configured Incorrectly - Cannot Change
Keyboard Configured Incorrectly - Cannot Change
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-27 14:12 EDT by paul bateson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-17 04:32:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paul bateson 2004-10-27 14:12:27 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Press SHIFT+2
2. 
3. 

Lots more incorrectly setup keystrokes.
  
Actual results:
I get the quotation marks

Expected results:
Should get the @ symbol (I press SHIFT + " to get the @ symbol)

Additional info:
I have tried to change the keybord through root keyboard menu option
but it will not modify. It is displaying US English but it is not. I
went to /etc/X11/rules . . . to manually try and modify the keyboard
but my knowledge level is not up to that task.

I do recall somewhere (?) that I was going through a language list and
and about 90% of the listings were "unknown." It was not significant
to me at the time but it may be now.

Fault level is high because I cannot type anything but alpha characters.
Comment 1 paul bateson 2004-10-27 17:30:59 EDT
The keyboard is described as "AT Translated Set 2." It is a generic
104 PC keyboard.

The changes through the menu - system settings - keyboard option
remains as long as the machine is not rebooted. The changes do not
survive a reboot.
Comment 2 paul bateson 2004-10-29 11:19:15 EDT
I located an X command called ¨setxkbmap.¨ Using it I was able to
return the keys to their normal places.

Unfortunately, the operation was not a total success. SHIFT + 6 must
be pressed twice to echo the ¨^¨ character. Also the apostrophe under
the quotation marks must be struck twice as well as the quotation
marks themselves.

The above characters do not look right. Maybe someone at your end can
check them in this message (HEX code) to see if they are what they
appear to be.

Thank You.
Comment 3 Miloslav Trmač 2005-02-18 18:40:34 EST
First of all, where does this happen?
- in X or on a virtual terminal ("text mode")?
- if in X, in KDE or GNOME?
Comment 4 Miloslav Trmač 2005-04-17 04:32:51 EDT
Please reopen this report if you can reproduce the problem on a recent release
and you can provide the requested data.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.