Bug 137403 - missing ipmi device nodes
missing ipmi device nodes
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 03:33 EDT by Martin Pool
Modified: 2011-11-03 13:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-03 13:17:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Pool 2004-10-28 03:33:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041003
Firefox/0.10.1

Description of problem:
RHEL4b1 includes the IPMI kernel modules.  When loaded they register
the  character device major 253 (according to /proc/devices), which
can be used by userspace applications to send IPMI commands.

This should be bound to /dev/ipmi0 and/or /dev/ipmidev/0, as it was in
RHEL3u3.  On my RHEL4b1 machine there are no nodes for IPMI at all. 
Maybe they got lost in the transition to udev?

If I run by hand "mknod /dev/ipmi0 c 253 0" then I can run my IPMI test.

I don't know enough about udev at the moment to work out the right way
to get it auto-added.
Comment 1 Harald Hoyer 2004-10-28 04:06:27 EDT
I don't know ipmi... according to _my_ /proc/devices ipmidev uses char
major 254...
according to devices.txt:
240-254 char    LOCAL/EXPERIMENTAL USE
240-254 block   LOCAL/EXPERIMENTAL USE
                Allocated for local/experimental use.  For devices not
                assigned official numbers, these ranges should be
                used in order to avoid conflicting with future 
                assignments.

so please fix the kernel module to provide the device through sysfs...

$ fgrep -ri ipmi /etc/makedev.d
/etc/makedev.d/linux-2.6.x:c $ROOT                 10 173  1   1 ipmikcs

Also MAKEDEV does not know about it.
Comment 2 Martin Pool 2004-10-28 21:46:06 EDT
From looking in the 2.6.7 kernel source, it does register_chrdev()
with major number 0, so it's dynamically assigned by the kernel; this
may be why the number has changed.  

Looking at the (kernel.org) 2.6.9 source I see this driver calls
devfs_mk_cdev, etc.  I don't know what happens to that on systems
without devfs.  I'll have a look in a bit.
Comment 3 Martin Pool 2004-10-28 23:40:59 EDT
On closer inspection, it turns out that the devices were not present
in RHEL3 either -- they had been manually created on the machine I was
looking at.  So since this is not a regression compared to RHEL3 you
might want to treat this as less serious.

I think it is still a bug though.  A proper fix probably requires
changing the module to properly register in sysfs/udev/whatever.
Comment 4 Mike Snitzer 2005-08-17 15:57:08 EDT
FYI, 2.6.12's ChangeLog contains:

[PATCH] Add sysfs support for the IPMI device interface

Note You need to log in before you can comment on or make changes to this bug.