Bug 137428 - automatic fstab entry doesn't work when selected.
automatic fstab entry doesn't work when selected.
Status: CLOSED DUPLICATE of bug 159464
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-10-28 09:34 EDT by Phil Knirsch
Modified: 2015-03-04 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 09:37:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Knirsch 2004-10-28 09:34:35 EDT
Description of problem:

If you want to create a new logical volume and select the

  "Check here if you would like to make an entry to /etc/fstab"

checkbox and click OK you'll get the following error message on the
text console and the dialog won't close:

Traceback (most recent call last):
  File "/usr/share/system-config-lvm/InputController.py", line 282, in
ok_new_vg
    apply(self.reset_tree_model, args)
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 135, in
reset_tree_model
    model.foreach(self.check_tree_items, name_to_be_selected)
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 147, in
check_tree_items
    selection.select_range(path, path)
TypeError: gtk.TreeSelection.select_range requires that selection mode
is gtk.SELECTION_MULTIPLE


Version-Release number of selected component (if applicable):

system-config-lvm-0.9.3-1.0

How reproducible:

Always

Steps to Reproduce:
1. Try to create new logical volume from an existing physical volume 
2. Activate the "Check here if you would like to make an entry to
/etc/fstab" checkbox
3. Click OK.
  
Actual results:
Dialog doesn't close, no entry is made to /etc/fstab

Expected results:

Dialog should close and an entry to /etc/fstab should have been written.

Additional info:
Comment 1 Jim Parsons 2004-11-11 09:37:02 EST
The fstab entry feature is being removed from this initial release and
pushed back to U1. A featurezilla ticket has been created for it.
Comment 2 Stanko Kupcevic 2005-09-14 15:14:25 EDT

*** This bug has been marked as a duplicate of 159464 ***

Note You need to log in before you can comment on or make changes to this bug.