This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 137451 - rh40-beta1, ata-piix driver bug causing LSI ICHxR RAID driver to fail
rh40-beta1, ata-piix driver bug causing LSI ICHxR RAID driver to fail
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Milburn
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 12:11 EDT by Manoj Jose
Modified: 2009-07-27 12:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 12:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manoj Jose 2004-10-28 12:11:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
If ata_piix driver is loaded LSI RAID driver could not get ICH5R / 
ICH6R RAID controller resources.  We had a chance to debug the issue. 
Here are our findings.

Ata_piix is configured to load for any PCI ID’s so it will try to 
load on MegaRAID ICHxR controller but it will fail at ata_bus_probe 
function call (see ata_device_add function in libata-core.c). 
But the successive tear down (unloading) process, in case of failure, 
is not implemented properly. So LSI RAID driver cannot access ICHxR 
resources and load. Is it possible to change ata_piix driver to fix 
this issue / prevent ata_piix from loading for LSI RAID controllers. 


Version-Release number of selected component (if applicable):
kernel-2.6..8-1.528.2.10

How reproducible:
Always

Steps to Reproduce:
1.Install RH40-Beta1 on system with ICHxR RAID controller
2.You can see ata_piix is not loading successfully.
3.
    

Additional info:
Comment 1 Tim Burke 2004-11-04 18:21:15 EST
Is LSI proposing a fix here?
Comment 3 Manoj Jose 2004-11-05 09:35:46 EST
LSI is not proposing the fix, there is lot to do to fix it. We are 
reporting the issue. 
Comment 4 Tim Burke 2004-11-07 21:58:37 EST
It appears to us that the appropriate resources are being released. 
Due to the fact that modprobe+rmmod+modprobe works properly.  Can you
be more helpful in identifying whats not being released?
Comment 6 Tim Burke 2004-11-07 22:03:45 EST
Is this failure also present on RHEL3?  Or is it specific to RHEL4?
Comment 7 Manoj Jose 2004-11-29 10:52:04 EST
Sorry for the delay. I was on vaction.

This problem happens when the ICHxR in Legacy mode, Not in native 
mode. To my knowledge this failure was present in different releases. 

This is the description of issue from our side 

From our debugging we saw that the ata_piix/libata driver fail at 
ata_bus_probe function call, if the chipset is configured in legacy 
mode. But the successive tear down (unloading) process in the driver, 
in case of failure, is not implemented properly(see ata_devive_add 
function in libata-core.c).  So LSI RAID driver cannot access ICHxR 
resources once after the ata_piix driver tries to load.

To make sure this is an issue with the ata_piix driver we avoided 
ata_piix in initrd image and booted the system, then installed LSI 
RAID driver. In this case every thing works fine. 

So we request following, if ata_piix fails to load, complete the 
unloading process perfectly, including the release of resources and 
ISR. 
 



Comment 17 David Milburn 2009-07-27 12:38:59 EDT
Closing this one out, code base as changed significantly and both ITs have
been closed out, please re-open if necessary.

Note You need to log in before you can comment on or make changes to this bug.