Bug 137458 - (IT_53283) EFI Boot Menu not updated when installing with external SCSI storage on a rx2620
EFI Boot Menu not updated when installing with external SCSI storage on a rx2620
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 12:38 EDT by Michael Raskey
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 09:40:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Raskey 2004-10-28 12:38:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ia64; en-US; rv:1.7)
Gecko/20040917 Firefox/0.9.3

Description of problem:
When installing Red Hat Enterprise Linux 3 AS Update 3 via HTTP or FTP
(using the text user interface) to external SCSI storage (via a SCSI
cable or FibreChannel) on a Badger Peak (rx2620), the EFI Boot Menu is
not properly setup to boot Linux.  I instead, get:

  Loading.: Red Hat Enterprise Linux AS
  Load of Red Hat Enterprise Linux AS failed: Not Found
  Press any key to continue

When installing via the normal SCSI cable, I installed using HTTP, and
only those components marked as "xyz Server".  I used the
Autopartition mechanism, and did not setup any kind of RAID.  The
installation does complete, but I get the above error message.  I am
able, though, to boot the OS via the built-in EFI Shell.

When installing via the FibreChannel SCSI, I installed using FTP, and
choose to install "Everything".  I again used the Autopartition
mechanism, and did not setup any kind of RAID.  As before with the
non-FibreChannel install, the installation completes normally, but I
get the same error message when attempting to load the OS via the EFI
Boot Menu.  In this case, I am NOT able to boot the OS via the
built-in EFI shell.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try yet - will add enclosure after doing so.


Additional info:
Comment 1 Glen A. Foster 2004-10-28 13:07:27 EDT
Raising severity to high.
Comment 2 Jeremy Katz 2004-10-29 09:23:16 EDT
What drive does Linux end up getting installed to?  If you boot the
system, can you use efibootmgr to add the install to the boot menu by
hand?
Comment 3 Michael Raskey 2004-10-29 12:51:13 EDT
This morning, I was able to replicate the problem.  I tried the
installation via the normal SCSI cable, using HTTP, but this time
installed "Everything".  I used the Autopartition mechanism, and did
not setup any kind of Software RAID (like last time).  The
installation does complete, but I get the same error message.

  Loading.: Red Hat Enterprise Linux AS
  Load of Red Hat Enterprise Linux AS failed: Not Found
  Press any key to continue

To answer your inquiries...

I installed Linux to /dev/sda on the JBOD (note that the server has no
disks in it).  I am able to boot the OS via the built-in EFI Shell at
\EFI\redhat\elilo.efi, and I can use the efibootmgr to add the install
to the boot menu by hand in this case.

I have not yet retried an installation to a JBOD hooked up via
FibreChannel.
Comment 4 Jeremy Katz 2004-10-29 13:34:24 EDT
What is the exact efibootmgr command you use to add the install to the
boot menu?  Just trying to see if there's an option that we're not
using or something.
Comment 5 Michael Raskey 2004-10-29 15:04:51 EDT
From the Boot Menu, I simply went to "Boot Configuration".  From
there, I could choose "Edit Boot Entry", and then edit the new option
manually.  What may be interest though, is that when I edit the new
entry, the description is okay as "Red Hat Enterprise Linux AS", but
the next dialog asks for "Load Options", and there were no load options!

To fix it, I modified the "Load Options" to be
"fs0:\EFI\redhat\elilo.efi".  After this change, I could then select
"Red Hat Enterprise Linux AS" from the "Boot Menu" and boot Linux as I
normally would expect to.
Comment 6 Michael Raskey 2004-10-29 17:54:54 EDT
Further investigation has indicated that this is most likely a
firmware problem.
Comment 7 Jeremy Katz 2004-11-01 09:40:08 EST
Closing due to it being a firmware problem

Note You need to log in before you can comment on or make changes to this bug.