Bug 137466 - no NR_IRQS defined when using irq.h include file
no NR_IRQS defined when using irq.h include file
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 13:43 EDT by Manfredo Hopp
Modified: 2015-01-04 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manfredo Hopp 2004-10-28 13:43:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Compiling a driver produces a not  NR_IRQS defined message. This
variable is defined in the irq_vectors_limits.h but the asm/irq.h is
only including irq_vectors.h.
I solved the problem including irq_vectors_limits.h in /asm/irq.h

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.503.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.Compile source with a reference to NR_IRQS including file linux/irq.h
2.
3.
    

Actual Results:  I solved the problem including irq_vectors_limits.h
in /asm/irq.h

Expected Results:  The compilation should work

Additional info:
Comment 1 Dave Jones 2004-10-28 19:45:24 EDT
what driver is this ?
Comment 2 Manfredo Hopp 2004-10-29 11:01:36 EDT
Eagle-usb for ADSL. See http://dev.eagle-usb.org
Comment 3 Dave Jones 2005-04-16 01:06:24 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.