Bug 137476 - CAN-2004-0888 xpdf integer overflows
CAN-2004-0888 xpdf integer overflows
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
impact=moderate,public=20041021
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 14:35 EDT by Josh Bressers
Modified: 2013-07-02 19:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 04:35:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2004-10-28 14:35:01 EDT
During a source code audit, Chris Evans and others discovered a number
of integer overflow bugs that affected all versions of xpdf.  An
attacker could construct a carefully crafted PDF file that could cause
xpdf to crash or possibly execute arbitrary code when opened.

tetex contains an internal version of xpdf.

See bug 135393 for patches and demo pdf files.

We should make sure this gets fixed in FC3
Comment 1 Jindrich Novy 2004-10-29 09:28:38 EDT
Hello Josh,

I built tetex-2.0.2-22 some time ago with the patch to dist-fc4.
Should I release an erratum for FC2, FC3, RHEL2.1, RHEL3?
Comment 3 Mark J. Cox (Product Security) 2004-11-09 05:19:33 EST
Errata needed for FC2 and FC3 to fix this
Comment 4 Jindrich Novy 2004-11-09 09:53:47 EST
tetex-2.0.2-21.1 is now built for FC3
tetex-2.0.2-14FC2 is now built in FC2

both with the patched xpdf.
Comment 5 Mark J. Cox (Product Security) 2005-03-18 04:35:10 EST
was pushed 2005-01-03

Note You need to log in before you can comment on or make changes to this bug.