Bug 137483 - autofs doesn't use LDAP defaults for LDAP maps
autofs doesn't use LDAP defaults for LDAP maps
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 15:23 EDT by Jack Neely
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 17:02:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jack Neely 2004-10-28 15:23:52 EDT
Description of problem:
When autofs is configured to use maps in LDAP the defaults from
/etc/ldap.conf are not used.

When I configure ldap.conf to

   ssl start_tls
   ssl on

Account information is looked up over an SSL connection, but querys
from autofs are still plain text.

Also, if I do not specify a server (the man page says the server is
optional) autofs does not function and exists because LDAP queries
fail.  It does not use the server supplied in /etc/ldap.conf

Version-Release number of selected component (if applicable):
autofs-4.1.3-17 + Nalin's patch from #137220

How reproducible:
Always

Steps to Reproduce:
1.  Setup autofs to pull maps from LDAP
2.  Make changes in /etc/ldap.conf
3.  See differences in LDAP querys from autofs and other ldap apps
Comment 1 Jack Neely 2004-10-28 15:26:15 EDT
For additional information that I forgot to add, I would like to be
able to have autofs do authenticated queries based off the information
in /etc/ldap.conf.  That's the goal here.  Possibly SASL auth from
your kerberos tickets, but I imagine that might be harder.
Comment 2 Chris Feist 2004-10-28 18:10:59 EDT
Try using editing the /etc/openldap/ldap.conf file.  The
/etc/ldap.conf file is owned by the nss_ldap package which autofs does
not use.  Autofs uses openldap.

[cfeist@gold cfeist]$ rpm -qf /etc/ldap.conf
nss_ldap-217-1
[cfeist@gold cfeist]$ rpm -qf /etc/openldap/ldap.conf
openldap-2.1.29-1

Please let me know if using your /etc/openldap/ldap.conf file works.
Comment 3 Jack Neely 2004-10-29 17:02:52 EDT
Blah...your are correct.  Thanks.  Closing as notabug.

Note You need to log in before you can comment on or make changes to this bug.