Bug 137490 - rhn_check returns a 500 traceback in dev.
rhn_check returns a 500 traceback in dev.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
:
Depends On:
Blocks: 123188
  Show dependency treegraph
 
Reported: 2004-10-28 16:22 EDT by Max Spevack
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 13:46:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2004-10-28 16:22:55 EDT
[root@vmware4 root]# rhn_check
We are out of serverUrl's to try. We tried:
https://xmlrpc.rhn.webdev.redhat.com/XMLRPC
Traceback (innermost last):
  File "/usr/sbin/rhn_check", line 305, in ?
    action = server.queue.get(up2dateAuth.getSystemId(),
ACTION_VERSION, Status)  File
"/usr/lib/python1.5/site-packages/rhn/_internal_xmlrpclib.py", line
984, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 49, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python1.5/site-packages/rhn/rpclib.py", line 308, in
_request
    verbose=self._verbose
  File "/usr/lib/python1.5/site-packages/rhn/transports.py", line 168,
in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python1.5/site-packages/rhn/transports.py", line 702,
in send_http
    response.status, response.reason, response.msg)
rhn._internal_xmlrpclib.ProtocolError: <ProtocolError for
xmlrpc.rhn.webdev.redhat.com /XMLRPC: 500 Internal Server Error>
Comment 1 Bret McMillan 2004-10-28 18:45:35 EDT
here's the server side traceback:


Exception reported from rhnxml.back-webdev.redhat.com
Time: Thu Oct 28 17:35:44 2004
Exception type server.rhnSQL.sql_base.SQLError
Exception while handling function queue.get
Request object information:
URI: /XMLRPC
Remote Host: 192.168.8.120
Server Name: rhnxml.back-webdev.redhat.com:80
Headers passed in:
        Accept-Encoding: identity
        Connection: close
        Content-Length: 2720
        Content-Type: text/xml
        Host: rhnxml.back-webdev.redhat.com
        User-Agent: rhn.rpclib.py/$Revision: 1.40 $
        Via: 1.1 xmlrpc.rhn.webdev.redhat.com
        X-Client-Version: 1
        X-ENV-HTTPS: on
        X-Forwarded-For: 192.168.36.154
        X-Host: xmlrpc.rhn.webdev.redhat.com:443
        X-Info: RPC Processor (C) Red Hat, Inc (version 1.44)
        X-Proxy-Forwarded-For: 192.168.36.154
        X-Proxy-Forwarded-Host: xmlrpc.rhn.webdev.redhat.com:443
        X-Proxy-Forwarded-Server: xmlrpc.rhn.webdev.redhat.com
        X-RHN-Client-Capability:
configfiles.upload(1)=1,configfiles.base64_enc(1)=1,script.run(1)=1,packages.verifyAll(1)=1,configfiles.diff(1)=1,configfiles.mtime_upload(1)=1,reboot.reboot(1)=1,packages.verify(1)=1,packages.runTransaction(1)=1,configfiles.deploy(1)=1
        X-RHN-Transport-Capability: follow-redirects=1
        X-Replace-Content-Active: 1
        X-Server-Hostname: xmlrpc.rhn.webdev.redhat.com
        X-Transport-Info: Extended Capabilities Transport (C) Red Hat,
Inc (version 1.40)
        X-Up2date-Version: 2.9.14
Extra information about this error:
SQL Error generated: (('Invalid LOB type code, 113, for column 1. LOBs
are not supported.',), {'SQL': "select script, username, groupname,
timeout, TO_CHAR(sysdate, 'YYYY-MM-DD HH24:MI:SS') as now from
rhnActionScript where action_id = :action_id", 'Params':
[(':action_id', 19817621)]})
 
Exception Handler Information
Traceback (innermost last):
  File "/usr/share/rhn/server/apacheRequest.py", line 103, in
call_function
    response = apply(func, params)
  File "/usr/share/rhn/server/handlers/xmlrpc/queue.py", line 264, in get
    ret = self.__getV2(action)
  File "/usr/share/rhn/server/handlers/xmlrpc/queue.py", line 77, in
__getV2
    result = method(self.server_id, action['id'])
  File "/usr/share/rhn/server/action/script.py", line 24, in run
    h.execute(action_id=action_id)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 99, in execute
    return apply(self._execute_wrapper, (self._execute, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 131, in
_execute_wrapper
    raise apply(sql_base.SQLError, ret)
SQLError: (('Invalid LOB type code, 113, for column 1. LOBs are not
supported.',), {'SQL': "select script, username, groupname, timeout,
TO_CHAR(sysdate, 'YYYY-MM-DD HH24:MI:SS') as now from rhnActionScript
where action_id = :action_id", 'Params': [(':action_id', 19817621)]})
Comment 2 Mihai Ibanescu 2004-11-01 11:30:50 EST
I could not reproduce it outside of the web code with a simple test
script, so I restarted apaches and the error went away. Not sure
what's going on there.
Comment 3 Max Spevack 2004-11-01 13:46:09 EST
Not happening anymore for me either.  Must have been a temporary
environment issue.

Closing.

Note You need to log in before you can comment on or make changes to this bug.