Bug 137500 - Fuzzy FireFox fonts
Summary: Fuzzy FireFox fonts
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-28 21:32 UTC by Owen Taylor
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 19:49:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FireFox rendering (22.76 KB, image/png)
2004-10-28 21:35 UTC, Owen Taylor
no flags Details
Mozilla rendering (22.34 KB, image/png)
2004-10-28 21:35 UTC, Owen Taylor
no flags Details

Description Owen Taylor 2004-10-28 21:32:54 UTC
Running firefox, I noticed that google was to my eye noticeably
fuzzier than with Mozilla.

The two attachments show mozilla and firefox rendering the same
page with the same font options (This was directly after profile
migration from Mozilla => FireFox)

Note with xmag that the pixels are not the same, which I would
have expected.

My *guess* here is that the FireFox gecko is asking for the
fonts at a non-integral size, causing fuzziness. Another possibility
is that it is just asking for the font at a different size that
doesn't render as well. But note the double-sided fuzz on the
left stroke of the 'R' - that shouldn't happen with our default
font hinting algorithms.

Comment 1 Owen Taylor 2004-10-28 21:35:10 UTC
Created attachment 105918 [details]
FireFox rendering

Comment 2 Owen Taylor 2004-10-28 21:35:50 UTC
Created attachment 105919 [details]
Mozilla rendering

Comment 3 Warren Togami 2004-10-28 23:04:46 UTC
Any different with PANGO enabled?


Comment 4 Owen Taylor 2004-10-28 23:26:46 UTC
This is whatever is the default for the FC3 RPMS. I don't know
if Pango is enabled in both, neither, or one and not the other.


Comment 5 Warren Togami 2004-10-29 01:24:30 UTC
Check your versions, because pango was enabled by default for a short
while, then disabled by default.  The latest are disabled by default,
but you can enable with MOZ_ENABLE_PANGO=1.  We plan on doing FC
updates real soon of both firefox and thunderbird that enables pango
by default while fixing several other bugs.

Comment 6 Owen Taylor 2004-10-29 02:19:25 UTC
$ rpm -q firefox mozilla
firefox-0.10.1-1.0PR1.20
mozilla-1.7.3-17

The same difference and same fuzzy fonts in firefox persist when
I run firefox with MOZ_ENABLE_PANGO=1.


Comment 7 Christopher Blizzard 2004-11-29 19:21:20 UTC
There shouldn't be any difference between the two.  Are you sure that
you're default font size in Firefox isn't some random zoomed size? 
(ctrl-0 will restore it to the default.)

Comment 8 Owen Taylor 2004-11-29 19:49:46 UTC
If you look closely at the 'G' in AGP you'll see that they are
actually picking up different fonts ... Luxi Sans for Mozilla
and some Helvetica clone (Nimbus Sans, Arial, whatever) for 
Firefox. 

Since I have my XP partition's fonts in my font path and the page 
specifies 'font-family:arial,sans-serif' it looks like Firefox
is behaving correctly, and Mozilla incorrectly.



Note You need to log in before you can comment on or make changes to this bug.