Bug 137537 - "usb-uhci.c interrupt status 3" appears when two USB devices installed
"usb-uhci.c interrupt status 3" appears when two USB devices installed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 08:14 EDT by floyd
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 20:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description floyd 2004-10-29 08:14:29 EDT
Description of problem:
System configuration:
CPU : NOCONA 3.6G stepping E-0 (D-0 also happen)
Memory : 512MB
HDD : SCSI 18G
North bridge : E7520(Lindenhurst)
South bridge : ICH 5 (Hance Rapids also happen)

I get the message "usb-uhci.c: c interrupt, status 3" followed by 
various frame numbers on all tty terminals when I plug in two USB 
devices(floppy and CD-ROM). 


Version-Release number of selected component (if applicable):
kernel 2.4.21-4.ELsmp

How reproducible:


Steps to Reproduce:
1. Plug in two USB devices(floppy and CD-ROM) and don't put any disk 
into devices.
2. Turn on the system power.
3. Boot to Linux ES release 3.
4. Login X-windows.
5.Toggle to a tty (cntl-alt-f1, etc)
6. Wait about 5 seconds and you will see the following messages.


Red Hat Enterprise Linux ES release 3 (Taroon)
Kernel 2.4.21-4.ELsmp on an i686

localhost login: usb-uhci.c: interrupt, status 3, frame# 448
usb-uhci.c: interrupt, status 3, frame# 474
usb-uhci.c: interrupt, status 3, frame# 512
usb-uhci.c: interrupt, status 3, frame# 560
usb-uhci.c: interrupt, status 3, frame# 646
usb-uhci.c: interrupt, status 3, frame# 882
usb-uhci.c: interrupt, status 3, frame# 950
usb-uhci.c: interrupt, status 3, frame# 1006
usb-uhci.c: interrupt, status 3, frame# 1134
usb-uhci.c: interrupt, status 3, frame# 1182
usb-uhci.c: interrupt, status 3, frame# 1268
usb-uhci.c: interrupt, status 3, frame# 1336
usb-uhci.c: interrupt, status 3, frame# 1452
usb-uhci.c: interrupt, status 3, frame# 1500
usb-uhci.c: interrupt, status 3, frame# 1570
usb-uhci.c: interrupt, status 3, frame# 1654
usb-uhci.c: interrupt, status 3, frame# 1712
usb-uhci.c: interrupt, status 3, frame# 1838
usb-uhci.c: interrupt, status 3, frame# 1886
usb-uhci.c: interrupt, status 3, frame# 1912
usb-uhci.c: interrupt, status 3, frame# 1950
usb-uhci.c: interrupt, status 3, frame# 18
usb-uhci.c: interrupt, status 3, frame# 56
usb-uhci.c: interrupt, status 3, frame# 128
usb-uhci.c: interrupt, status 3, frame# 220

We use the USB Protocol Analyzer to dump the data when interrupt 
status 3 occur in frame#560.
The following is the data :

15296__| F(S) Sync(00000001) SOF(0xA5) Frame #(556) CRC5(0x01) EOP
(250 ns) 
_______| Time-stamp(00005.1728 1181) 
_______|______________________________________________________________
_________
15297__| SE0(166 ns) Time-stamp(00005.1736 0975) 
_______|______________________________________________________________
_________
15298__| F(S) Sync(00000001) SOF(0xA5) Frame #(557) CRC5(0x1E) EOP
(233 ns) 
_______| Time-stamp(00005.1736 1170) 
_______|______________________________________________________________
_________
15299__| SE0(150 ns) Time-stamp(00005.1744 0964) 
_______|______________________________________________________________
_________
15300__| F(S) Sync(00000001) SOF(0xA5) Frame #(558) CRC5(0x1C) EOP
(250 ns) 
_______| Time-stamp(00005.1744 1158) 
_______|______________________________________________________________
_________
15301__| SE0(150 ns) Time-stamp(00005.1752 0953) 
_______|______________________________________________________________
_________
15302__| F(S) Sync(00000001) SOF(0xA5) Frame #(559) CRC5(0x03) EOP
(250 ns) 
_______| Time-stamp(00005.1752 1147) 
_______|______________________________________________________________
_________
15303__| F(S) Sync(00000001) IN(0x96) ADDR(3) ENDP(2) CRC5(0x1E) EOP
(250 ns) 
_______| Time-stamp(00005.1752 1342) 
_______|______________________________________________________________
_________
15304__| F(S) Sync(00000001) STALL(0x78) EOP(233 ns) 
_______| Time-stamp(00005.1752 1551) 
_______|______________________________________________________________
_________
15305__| SE0(150 ns) Time-stamp(00005.1760 0942) 
_______|______________________________________________________________
_________
15306__| F(S) Sync(00000001) SOF(0xA5) Frame #(560) CRC5(0x14) EOP
(233 ns) 
_______| Time-stamp(00005.1760 1136) 
_______|______________________________________________________________
_________
15307__| SE0(166 ns) Time-stamp(00005.1768 0930) 
_______|______________________________________________________________
_________
15308__| F(S) Sync(00000001) SOF(0xA5) Frame #(561) CRC5(0x0B) EOP
(233 ns) 
_______| Time-stamp(00005.1768 1125) 
_______|______________________________________________________________
_________
15309__| F(S) Sync(00000001) SETUP(0xB4) ADDR(3) ENDP(0) CRC5(0x0A) 
EOP(233 ns) 
_______| Time-stamp(00005.1768 1320) 
_______|______________________________________________________________
_________
15310__| F(S) Sync(00000001) DATA0(0xC3) Data(8 bytes) CRC16(0x60A9) 
_______| EOP(250 ns) Time-stamp(00005.1768 1505) 
_______|______________________________________________________________
_________
15311__| F(S) Sync(00000001) ACK(0x4B) EOP(233 ns) Time-stamp
(00005.1768 2023) 
_______|______________________________________________________________
_________
15400__| F(S) Sync(00000001) IN(0x96) ADDR(3) ENDP(0) CRC5(0x0A) EOP
(250 ns) 
_______| Time-stamp(00005.1771 2920) 
_______|______________________________________________________________
_________
15401__| F(S) Sync(00000001) DATA1(0xD2) Data(0 bytes) CRC16(0x0000) 
_______| EOP(233 ns) Time-stamp(00005.1771 3128) 
_______|______________________________________________________________
_________
15402__| F(S) Sync(00000001) ACK(0x4B) EOP(250 ns) Time-stamp
(00005.1771 3330) 
_______|______________________________________________________________
_________
15403__| SE0(150 ns) Time-stamp(00005.1776 0919) 
_______|______________________________________________________________
_________
15404__| F(S) Sync(00000001) SOF(0xA5) Frame #(562) CRC5(0x09) EOP
(250 ns) 
_______| Time-stamp(00005.1776 1113) 
_______|______________________________________________________________
_________
15405__| SE0(150 ns) Time-stamp(00005.1784 0908) 
_______|______________________________________________________________
_________
15406__| F(S) Sync(00000001) SOF(0xA5) Frame #(563) CRC5(0x16) EOP
(250 ns) 
_______| Time-stamp(00005.1784 1102) 
_______|______________________________________________________________
_________
15411__| F(S) Sync(00000001) IN(0x96) ADDR(3) ENDP(2) CRC5(0x1E) EOP
(233 ns) 
_______| Time-stamp(00005.1784 2217) 
_______|______________________________________________________________
_________
15412__| F(S) Sync(00000001) DATA0(0xC3) Data(13 bytes) CRC16(0x9DDC) 
_______| EOP(233 ns) Time-stamp(00005.1784 2425) 
_______|______________________________________________________________
_________
15413__| F(S) Sync(00000001) ACK(0x4B) EOP(233 ns) Time-stamp
(00005.1784 3147) 
_______|______________________________________________________________
_________
15414__| SE0(150 ns) Time-stamp(00005.1792 0895) 
_______|______________________________________________________________
_________
15415__| F(S) Sync(00000001) SOF(0xA5) Frame #(564) CRC5(0x08) EOP
(233 ns) 
_______| Time-stamp(00005.1792 1091) 
_______|______________________________________________________________
_________
15416__| SE0(166 ns) Time-stamp(00005.1800 0885) 
_______|______________________________________________________________
_________
15417__| F(S) Sync(00000001) SOF(0xA5) Frame #(565) CRC5(0x17) EOP
(250 ns) 
_______| Time-stamp(00005.1800 1080) 
_______|______________________________________________________________
_________
15418__| F(S) Sync(00000001) OUT(0x87) ADDR(3) ENDP(1) CRC5(0x07) EOP
(250 ns) 
_______| Time-stamp(00005.1800 1274) 
_______|______________________________________________________________
_________
15419__| F(S) Sync(00000001) DATA0(0xC3) Data(31 bytes) CRC16(0x06A9) 
_______| EOP(250 ns) Time-stamp(00005.1800 1459) 
_______|______________________________________________________________
_________
15420__| F(S) Sync(00000001) ACK(0x4B) EOP(233 ns) Time-stamp
(00005.1800 2897) 
_______|______________________________________________________________
_________
15421__| SE0(150 ns) Time-stamp(00005.1808 0873) 
_______|______________________________________________________________
_________
15422__| F(S) Sync(00000001) SOF(0xA5) Frame #(566) CRC5(0x15) EOP
(250 ns) 
_______| Time-stamp(00005.1808 1068) 
_______|______________________________________________________________
_________
15423__| SE0(150 ns) Time-stamp(00005.1816 0863) 
_______|______________________________________________________________
_________
15424__| F(S) Sync(00000001) SOF(0xA5) Frame #(567) CRC5(0x0A) EOP
(250 ns) 
_______| Time-stamp(00005.1816 1057)  
  
Actual results:
I see the "usb-uhci.c: c interrupt, status 3" message.

Expected results:
Should not see the message.

Additional info:
1. No matter USB legacy function enable or disable , the message 
still happen.
2. If I unplug and plug the devices again, the message will stop.
Comment 1 Ernie Petrides 2004-10-29 20:08:41 EDT

*** This bug has been marked as a duplicate of 122892 ***
Comment 2 John Flanagan 2004-12-20 15:56:51 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.