Bug 137545 - Applications> Graphics> PDF Viewer loads ggv, nautilus loads PDFs using gpdf
Applications> Graphics> PDF Viewer loads ggv, nautilus loads PDFs using gpdf
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Nickell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 09:22 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 18:04:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-10-29 09:22:48 EDT
User-Agent:       
Build Identifier: 

Applications> Graphics> PDF Viewer loads ggv, nautilus loads PDFs using gpdf

Reproducible: Always
Steps to Reproduce:
x
Comment 1 Bryan W Clark 2004-11-01 01:16:13 EST
> Applications> Graphics> PDF Viewer loads ggv, 

I don't see this, can you right click on this menu item and view it's properties
to make sure it has 'gpdf %U' in the Command field.

> nautilus loads PDFs using gpdf

GGV should be the default PDF viewer when launched from Nautilus.
Comment 2 Need Real Name 2004-11-02 03:17:40 EST
Ack. I was wrong. Other way around.

Applications> Graphics> PDF Viewer loads gpdf
but nautilus loads PDFs using ggv

They should be the same, shouldn't they?
Comment 3 Bryan W Clark 2004-11-02 03:56:38 EST
ah yes.  ggv (Postcript Viewer) should be the default for now.  GPDF
is having some serious crasher issues right now, so we've fallen back
to ggv instead.  This is a problem we need to revisit for FC4,
hopefully we'll have worked out a single document viewer in upstream
GNOME by then and can scrap all the other ones.
Comment 4 Need Real Name 2004-11-04 04:57:40 EST
"GPDF is having some serious crasher issues right now, so we've fallen back to
ggv instead."

But Applications> Graphics> PDF Viewer still loads gpdf
Comment 5 Bryan W Clark 2004-11-04 15:57:40 EST
We've fallen back to registering ggv as the default viewer for the
mime types associated with pdfs.  Most PDFs are opened via a default
viewer method (like web browser, nautilus) and not really from the
menu item, then finding the PDF.

You make a good point here, but I don't plan on removing 'PDF Viewer'
from the menus or making it launch ggv instead.  GPDF is getting a lot
of upstream work on integrating with the GNOME desktop, the
maintainers of both ggv and gpdf are working to make a single document
viewer that will replace both of these apps.  So I'd like to wait and
see what happens with that.
Comment 6 Bryan W Clark 2005-02-12 23:43:53 EST
Please try evince as a replacement to gpdf and ggv.  It's still in
it's early stages but is set to deprecate both of those.  You may have
to grab it from rawhide.  See http://www.gnome.org/projects/evince/
Comment 7 Need Real Name 2005-02-13 04:19:39 EST
Great. I'll wait until FC4 because of the gtk2 2.6 dependency.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.