Bug 1375716 - [RFE] Show the size of a repository in MBs on Disk
Summary: [RFE] Show the size of a repository in MBs on Disk
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords: FutureFeature
: 1375717 1401663 (view as bug list)
Depends On: 1375717
Blocks: 1545876 260381
TreeView+ depends on / blocked
 
Reported: 2016-09-13 20:11 UTC by Bryan Kearney
Modified: 2018-09-19 15:12 UTC (History)
12 users (show)

(edit)
Clone Of:
: 1375717 (view as bug list)
(edit)
Last Closed: 2018-09-04 19:04:04 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 2261 Normal NEW As a user, I can see the total size in bytes that a repository's files use on disk 2016-11-21 18:51 UTC
Foreman Issue Tracker 17432 None None None 2016-11-21 18:47 UTC

Description Bryan Kearney 2016-09-13 20:11:11 UTC
Customer would like to know the size of a repository on disk. In a simplistic model, this would be the sum of the size of all the packages. In a more robust setting, this would also show the deduplicated size,

Comment 1 Dennis Kliban 2016-09-20 17:48:29 UTC
I can think of 2 use cases that are being described here:

1) User wants to know how much disk space is used to store all of his content.

2) User wants know how much space is needed to export a particular repository.

4) User wants to know how much disk space is needed to perform a sync. 

There are probably other use cases, but these the main ones. Which of these or others do we want to cover?

Comment 2 Brad Buckingham 2016-11-21 18:46:58 UTC
Created redmine issue http://projects.theforeman.org/issues/17432 from this bug

Comment 3 Brian Bouterse 2016-11-21 18:48:35 UTC
*** Bug 1375717 has been marked as a duplicate of this bug. ***

Comment 4 pulp-infra@redhat.com 2016-11-21 18:51:47 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 5 pulp-infra@redhat.com 2016-11-21 18:51:50 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 7 Bryan Kearney 2017-10-12 13:25:13 UTC
*** Bug 1401663 has been marked as a duplicate of this bug. ***

Comment 8 Bryan Kearney 2017-10-12 13:28:30 UTC
CLI tool can be found at https://bugzilla.redhat.com/show_bug.cgi?id=1401663

Comment 9 Bryan Kearney 2018-09-04 18:54:26 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 10 Bryan Kearney 2018-09-04 19:04:04 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.