Bug 137664 - libc-2.3.3.so not accessible on i586
Summary: libc-2.3.3.so not accessible on i586
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: selinux-policy-targeted (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i586 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-30 10:25 UTC by Simon Matter
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 13:33:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Simon Matter 2004-10-30 10:25:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041026 Firefox/1.0RC1

Description of problem:
There seems to be a problem in the targeted policy which affects my
test server with AMD K6-2 using i586 kernel.


Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.16-2

How reproducible:
Always

Steps to Reproduce:
1. Install RHES4 Beta1 on AMD K6-2 CPU
2. Boot the box
3. Check for selinux messages
    

Actual Results:  Some services don't start because of this:
audit(1099092862.190:0): avc:  denied  { read } for  pid=1888
exe=/sbin/minilogd path=/init dev=rootfs ino=12
scontext=user_u:system_r:syslogd_t
tcontext=system_u:object_r:unlabeled_t tclass=file
audit(1099092862.191:0): avc:  denied  { execute } for  pid=1888
path=/lib/tls/i486/libc-2.3.3.so dev=dm-0 ino=473342
scontext=user_u:system_r:syslogd_t tcontext=system_u:object_r:lib_t
tclass=file
audit(1099092862.210:0): avc:  denied  { read } for  pid=1890
exe=/sbin/minilogd path=/init dev=rootfs ino=12
scontext=user_u:system_r:syslogd_t
tcontext=system_u:object_r:unlabeled_t tclass=file
audit(1099092862.211:0): avc:  denied  { execute } for  pid=1890
path=/lib/tls/i486/libc-2.3.3.so dev=dm-0 ino=473342
scontext=user_u:system_r:syslogd_t tcontext=system_u:object_r:lib_t
tclass=file
audit(1099092862.415:0): avc:  denied  { read } for  pid=1896
exe=/sbin/minilogd path=/init dev=rootfs ino=12
scontext=user_u:system_r:syslogd_t
tcontext=system_u:object_r:unlabeled_t tclass=file


Expected Results:  The selinux policy should work on every CPU.

Additional info:

This is the same problem I already posted for FC3-test2 which was
fixed there. See bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133958
and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133505

Comment 1 Daniel Walsh 2004-10-31 11:59:45 UTC
You need to update to a later policy.  Either the one in Rawhide or
the one coming out in Beta 2.

Dan


Note You need to log in before you can comment on or make changes to this bug.