Bug 137676 - gtk2 uses /etc/gtk-2.0/%buildhost while librsvg uses /etc/gtk-2.0/%target
gtk2 uses /etc/gtk-2.0/%buildhost while librsvg uses /etc/gtk-2.0/%target
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-30 10:23 EDT by Carlos Romero
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 10:44:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gtk2.spec diff (845 bytes, patch)
2004-10-30 10:24 EDT, Carlos Romero
no flags Details | Diff
updated lib64 patch (2.42 KB, patch)
2004-10-30 10:25 EDT, Carlos Romero
no flags Details | Diff

  None (edit)
Description Carlos Romero 2004-10-30 10:23:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041023 Epiphany/1.4.4

Description of problem:

librsvg.spec uses %{_arch}-%{_host_vendor}-%{_host_os}, which is
i386-redhat-linux-gnu.
gtk2.spec uses %_host, which is i686-redhat-linux.
librsvg %post and %postun fail with the mismatch.

an updated lib64 patch and spec diff will be attached.


Version-Release
2.4.13-5

How reproducible:
Always

Steps to Reproduce:
1.build gtk2 and librsvg on a i686, default target of i386
Comment 1 Carlos Romero 2004-10-30 10:24:06 EDT
Created attachment 105974 [details]
gtk2.spec diff
Comment 2 Carlos Romero 2004-10-30 10:25:21 EDT
Created attachment 105975 [details]
updated lib64 patch
Comment 3 Bill Nottingham 2004-11-01 16:08:13 EST
Shouldn't librsvg2 be fixed instead?
Comment 4 Carlos Romero 2004-11-02 07:45:33 EST
librsvg2 is using the target, seems more correct than using the build
machine cpu.
Comment 5 Matthias Clasen 2004-11-03 10:34:57 EST
The reason for using _host is that it is necessary to use the same
triplet as the one configure works with. See the extra contortions we
go through to make sure that is the case. 

I'll change librsvg2 to use _host again.
Comment 6 Carlos Romero 2004-11-05 13:20:17 EST
gnome-utils also uses %{_arch}-%{_host_vendor}-%{_host_os}, causing
the %post scriptlet to fail.

/usr/bin/update-gtk-immodules: line 27:
/etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules: No such file or
directory
error: %post(gnome-utils-2.8.1-1.i386) scriptlet failed, exit status 1

Note You need to log in before you can comment on or make changes to this bug.