Bug 137737 - yum on x86_64 won't install i386 packet with same name as a x86_64 package that's allready installed
yum on x86_64 won't install i386 packet with same name as a x86_64 package th...
Status: CLOSED DUPLICATE of bug 137736
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-31 14:21 EST by Ernst Persson
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ernst Persson 2004-10-31 14:21:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041029 Firefox/1.0RC1

Description of problem:
I have glibc.x86_64 installed but not the .i686 version.
Yum doesn't want to install the i686 version.

Here's the output from yum:

[root@zapp Desktop]# yum list glibc
Setting up Repo:  development-cz
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3635/3635
Installed Packages
glibc.x86_64                             2.3.3-74               installed
Available Packages
glibc.i686                               2.3.3-74              
development-cz

[root@zapp Desktop]# yum install glibc
Setting up Install Process
Setting up Repo:  development-cz
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3635/3635
Nothing to do

[root@zapp Desktop]# yum install glibc.i686
Setting up Install Process
Setting up Repo:  development-cz
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3635/3635
Nothing to do

[root@zapp Desktop]# yum install glibc-2.3.3-74.i686.rpm
Setting up Install Process
Setting up Repo:  development-cz
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3635/3635
Examining glibc-2.3.3-74.i686.rpm: glibc - 2.3.3-74.i686
glibc-2.3.3-74.i686.rpm: installed versions are equal or greater
glibc-2.3.3-74.i686.rpm: installed versions are equal or greater
No Match for argument glibc-2.3.3-74.i686.rpm
Nothing to do

Version-Release number of selected component (if applicable):
yum-2.1.11-2.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
Try to install i386 package when the x86_64 version allready is installed.

Additional info:
Comment 1 Stefan Hoelldampf 2004-10-31 14:33:46 EST
Seems to be a duplicate of bug 137736
Comment 2 Seth Vidal 2004-10-31 16:44:46 EST
 

*** This bug has been marked as a duplicate of 137736 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.