Bug 137783 - utf8 patches doesn't build with gcc 2.95
Summary: utf8 patches doesn't build with gcc 2.95
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-01 09:39 UTC by Nickolay V. Shmyrev
Modified: 2013-07-02 23:03 UTC (History)
2 users (show)

Fixed In Version: 4.6.1-0.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 12:50:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to patches :) (2.71 KB, patch)
2004-11-01 09:41 UTC, Nickolay V. Shmyrev
no flags Details | Diff
utf8-fix patch fixed to build with -ansi (8.69 KB, patch)
2004-11-02 16:37 UTC, Leonard den Ottolander
no flags Details | Diff
utf8-input patch fixed to build with -ansi (82.86 KB, patch)
2004-11-02 16:38 UTC, Leonard den Ottolander
no flags Details | Diff

Description Nickolay V. Shmyrev 2004-11-01 09:39:29 UTC
As asked in bug #116233

Additional Comment #17 From Jindrich Novy (jnovy@redhat.com)  on
2004-10-29 11:02 -------

Nickolay,

however, since you're compiling mc from the Red Hat distribution src
rpm, I'm interested in issues regarding even the problems you
mentioned with gcc-2.95, because it would show some incorrectnesses
not only in the upstream source code, but in the source code I add in
patches or in spec file.

Could you please file a new bug for it?

thanks,
Jindrich

Comment 1 Nickolay V. Shmyrev 2004-11-01 09:41:23 UTC
Created attachment 106006 [details]
Patch to patches :)

Comment 2 Leonard den Ottolander 2004-11-01 12:20:39 UTC
I contacted Vladimir Nadvornik about this issue.

Your patch does not remove the #define _ISOC99_SOURCE from edit.h,
which is introduced in the utf8-input patch. I think this is necessary
to avoid warnings at least.

Could you complete your patch and attach it here again? And an email
to mc-devel@gnome.org with this patch would be fine as well.


Comment 3 Jindrich Novy 2004-11-01 13:10:56 UTC
... but please don't make diff to patches, even though it's funny,
it's absolutely unreadable ;-)

Could you post here the improved version of the utf8-input patch then?

Comment 4 Leonard den Ottolander 2004-11-02 16:37:50 UTC
Created attachment 106072 [details]
utf8-fix patch fixed to build with -ansi

Comment 5 Leonard den Ottolander 2004-11-02 16:38:39 UTC
Created attachment 106073 [details]
utf8-input patch fixed to build with -ansi

Comment 6 Nickolay V. Shmyrev 2004-11-02 18:56:02 UTC
Thanks and sorry for being so slow.

Comment 7 Jindrich Novy 2004-11-08 12:50:02 UTC
Nickolay, you needn't to excuse, you weren't slow but Leonard was too
quick ;-)

It's now fixed in mc-4.6.1-0.9.


Note You need to log in before you can comment on or make changes to this bug.