Bug 137794 - unescaped RPM macros place excessive garbage text into changelog
unescaped RPM macros place excessive garbage text into changelog
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libglade (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-01 09:02 EST by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 09:32:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2004-11-01 09:02:42 EST
Description of problem:
In the SPEC file there are unescaped RPM macros, namely %makeinstall 
and %configure. These are unfortunately expanded in the changelog 
(rpm -qp --changelog $file.rpm), and are quite annoying.

Version-Release number of selected component (if applicable):
0.17-15

How reproducible:
always

Steps to Reproduce:
1. tail +`fgrep -n %changelog libglade.spec | cut -d: -f1`  libglade.
spec | fgrep '%configure'

Actual results:
1. - Use %makeinstall, since that is required when %configure is 
used.

Expected results:
1. - Use %%makeinstall, since that is required when %%configure is 
used.

Additional info:
Have a look at the beautifully expanded changelog yourself. :-/ I'd 
rather not quote all of it here...

This is very related to bug #127050 which I posted against libglade2 
(2!) quite some time ago. :)
Comment 1 Matthias Clasen 2004-11-03 09:32:19 EST
libglade was dropped from FC3...
Comment 2 Moritz Barsnick 2004-11-03 12:13:28 EST
Oops, I still found it in FC devel against which I posted this. Is it 
still in Rawhide or future RHEL?

Note You need to log in before you can comment on or make changes to this bug.