Bug 137796 - Category=TextEditor items are missing from menus
Summary: Category=TextEditor items are missing from menus
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-01 14:24 UTC by Rex Dieter
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-06 19:27:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add 'Editors' menu (551 bytes, patch)
2004-11-01 15:30 UTC, Rex Dieter
no flags Details | Diff

Description Rex Dieter 2004-11-01 14:24:08 UTC
Any item containing
Categories=TextEditor
is missing from the menus.  

A concrete problem, is that it essentially makes KWrite and Kate
invisible to a (KDE) end-user.  Worse, the only items one can select
to one text/plain files are
vim (vim-X11)
Emacs
KWord

Comment 1 Rex Dieter 2004-11-01 15:30:54 UTC
Created attachment 106018 [details]
Add 'Editors' menu 

possible fix 1: Add top-level 'Editors' menu.

Else, TextEditors could be added to 'Accessories', I suppose.

Comment 2 Rex Dieter 2004-11-01 17:41:06 UTC
Comment on attachment 106018 [details]
Add 'Editors' menu 

>--- redhat-menus-1.13/menus/applications.menu.Editors	2004-03-16 14:12:53.000000000 -0600
>+++ redhat-menus-1.13/menus/applications.menu	2004-11-01 09:22:23.421320104 -0600
>@@ -70,6 +70,17 @@
>     </Include>
>   </Menu> <!-- End Development Tools -->
> 
>+  <!-- Editors -->
>+  <Menu>
>+    <Name>Editors</Name>
>+    <Directory>kde-editors.directory</Directory>
>+    <Include>
>+      <And>
>+        <Category>TextEditor</Category>
>+      </And>
>+    </Include>
>+  </Menu> <!-- End Editors -->
>+
>   <!-- Edutainment -->
>   <Menu>
>     <Name>Edutainment</Name>

Comment 3 Rex Dieter 2004-11-02 22:15:19 UTC

*** This bug has been marked as a duplicate of 122181 ***

Comment 4 Rex Dieter 2004-11-24 16:51:47 UTC
An errata was released (redhat-menus-3.7.1-1.fc3), why wasn't this fix
included?

Comment 5 Rex Dieter 2005-03-22 15:30:46 UTC
Reopening per bug #122181#c12

Comment 6 Ngo Than 2005-03-22 18:06:33 UTC
ok, it's perhaps better to add TextEditors in Accessories. It's a another fix
--- applications.menu.orig      2005-03-22 17:29:10.000000000 +0100
+++ applications.menu   2005-03-22 17:50:53.000000000 +0100
@@ -45,13 +45,15 @@
     <Directory>Accessories.directory</Directory>
     <Include>
       <And>
-        <Category>Utility</Category>
-        <Not>
-          <Category>System</Category>
-        </Not>
+         <Or>
+           <Category>Utility</Category>
+           <Category>TextEditor</Category>
+         </Or>
+         <Not>
+           <Category>System</Category>
+           <Category>Development</Category>
+         </Not>
       </And>
-      <Filename>kde-kwrite.desktop</Filename>
-      <Filename>kde-KEdit.desktop</Filename>
     </Include>
   </Menu> <!-- End Accessories -->

@@ -63,7 +65,6 @@
       <And>
         <Category>Development</Category>
       </And>
-      <Filename>kde-kate.desktop</Filename>
     </Include>
   </Menu> <!-- End Development Tools -->


Comment 7 Rex Dieter 2005-03-22 18:11:28 UTC
Yes, much better, thanks.

Comment 8 Rex Dieter 2005-08-06 19:27:32 UTC
fixed w/redhat-menus-3.8


Note You need to log in before you can comment on or make changes to this bug.