Bug 137807 - Upgrade FC2 -> FC3rc5 fails
Upgrade FC2 -> FC3rc5 fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-01 12:18 EST by Andrew W. Donoho
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 22:42:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is a gzipped tar archive of every file in /root (30.00 KB, application/octet-stream)
2004-11-01 13:27 EST, Andrew W. Donoho
no flags Details
New root Logs (40.00 KB, application/octet-stream)
2004-11-02 12:40 EST, Andrew W. Donoho
no flags Details
New Anaconda Logs (10.00 KB, application/octet-stream)
2004-11-02 13:02 EST, Andrew W. Donoho
no flags Details

  None (edit)
Description Andrew W. Donoho 2004-11-01 12:18:54 EST
Description of problem:
Upgrade FC2 -> FC3rc5 upgrade fails


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Take working FC2 i686 smp system using LVM on root 
2.Upgrade via FC3rc5 Rescue CD doing an install via HTTP.
3.Reboot to failure.
  
Actual results:
I tried to upgrade an FC2 SMP i686 system on an LVM managed disk. 
The system did not update grub properly. When I hand edited grub to
point at the only installed kernel, the 
system then panicked. 

Later:

I tried re-updating the system. I got the same error:

After NASH loads:

mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed 2
Kernel panic - not syncing: Attempted to kill init!

	I'll keep the system this way for awhile waiting for someone's 
response to these messages. Otherwise I'll scrub the drive and restart 
from scratch. Bear in mind that this system was running fine under 
FC2.


Expected results:
FC2 -> FC3rc5 upgrade should work perfectly. This system has run
Redhat since the days of 6.*.


Additional info:

You tell me. The system will boot under the FC3rc5 Rescue disc. The
disk is readable. What do you want?
Comment 1 Jeremy Katz 2004-11-01 13:07:24 EST
Can you grab /root/upgrade.log by booting into rescue mode, mounting
your disk and then chroot'ing into /mnt/sysimage?
Comment 2 Andrew W. Donoho 2004-11-01 13:27:07 EST
Created attachment 106023 [details]
Here is a gzipped tar archive of every file in /root

More than you asked for... every file in the directory.
I await your next request.
Comment 3 Jeremy Katz 2004-11-01 13:43:06 EST
That upgrade.log only has a couple of packages being upgraded and
isn't the full system upgrade... did you try doing another upgrade
afterwards?
Comment 4 Andrew W. Donoho 2004-11-01 14:13:55 EST
Yes, I thought that the upgrade went wonky and that reapplying the upgrade would 
automagically fix things. If, due to the second upgrade, things are hopeless, I would be 
willing to reinstall FC2 and do the upgrade again to see if this is repeatable.

Andrew
Comment 5 Jeremy Katz 2004-11-01 14:17:09 EST
It, unfortunately, at least clobbers the chances I have of seeing
what's going on.  My FC2-> FC3 upgrades are working here, but there
definitely could be oddness involved (the dev->udev transition being
the primary culprit of such a thing).

If you could reproduce it and then grab /root/upgrade.log and
/var/log/anaconda*, that would help
Comment 6 Andrew W. Donoho 2004-11-01 14:28:43 EST
OK, I'll try to reproduce. Here is my basic plan:

Scrub machine and perform new install of FC2. I'll try to select the same packages.
Setup run level 3.
Upgrade all packages.
Turn on smartd.
Install the only piece of user compiled code: djbdns' dnscache.

Do the same FC2 -> FC3rc5 over http upgrade.
Cross fingers and toes for failure.   ;-)

This will take some time. Probably won't be done until later this evening.

Thanks for working this with me,
Andrew
Comment 7 Andrew W. Donoho 2004-11-02 12:40:07 EST
Created attachment 106075 [details]
New root Logs

I've reinstalled FC2 on a newly formatted drive with three primary partitions:
/boot, swap and / (as an LVM2 logical volume). I then upgraded via yum to the
latest FC2 packages. I verified that basic trhings function like X, ncftp, etc.
I then rebooted with FC3rc5 rescue CD and did an upgrade install via HTTP. Upon
rebooting, grub is still looking for the old FC2 kernel 2.6.8-1.521smp. No
other kernels are listed. This is the same behavior I noticed the first time I
did this. Other than gzipping the /root directory, the system is untouched.
Tell me what you need and I'll try to get it for you.
Andrew
Comment 8 Andrew W. Donoho 2004-11-02 13:02:26 EST
Created attachment 106077 [details]
New Anaconda Logs

Oops....forgot to get you these...
Comment 9 Jeremy Katz 2004-11-03 15:35:57 EST
Okay, I see what's going on.  In the dev -> udev transition, the
trigger doesn't do enough to make sure that the right device nodes get
created for mkinitrd to be able to find stuff.

Added an lvm vgmknodes to the udev trigger and built. 

Thanks for looking into this.
Comment 10 Andrew W. Donoho 2004-11-03 16:29:54 EST
OK. I'm glad it is a real problem.

I will go ahead and reinstall FC2 to prepare to test if the bug is fixed with the next FC3 
release candidate.

Andrew
Comment 11 Andrew W. Donoho 2004-11-10 22:42:31 EST
I've been able to successfully update FC2 to FC3 with the final FC3.

Note You need to log in before you can comment on or make changes to this bug.