Bug 137811 - firstboot doesn't work without rhgb enabled
Summary: firstboot doesn't work without rhgb enabled
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-01 18:19 UTC by Elliot Lee
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-06 21:59:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elliot Lee 2004-11-01 18:19:36 UTC
Last I tried (admittedly a few weeks ago), firstboot didn't work
without rhgb enabled.

Comment 1 Elliot Lee 2004-11-01 18:20:47 UTC
One possible race condition on this codepath in firstboot seemed to be
that if xrdb finishes running before the window manager connects to
the X server, the X server may terminate ('last client has
disconnected') and not be there when firstboot needs it to be.

Comment 2 Bill Nottingham 2004-11-02 03:07:11 UTC
Works for me in a quick test. The text mode bits work too.


Note You need to log in before you can comment on or make changes to this bug.