Bug 1378332 - devtoolset-6-libatomic-devel.aarch64 does not install on rhel-7.2
Summary: devtoolset-6-libatomic-devel.aarch64 does not install on rhel-7.2
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: gcc
Version: DTS 6.0 RHEL 7
Hardware: aarch64
OS: Linux
low
low
Target Milestone: alpha
: 6.0
Assignee: Jakub Jelinek
QA Contact: Martin Cermak
Lenka Špačková
URL:
Whiteboard:
Depends On: 1362438
Blocks: 1371037
TreeView+ depends on / blocked
 
Reported: 2016-09-22 07:24 UTC by Martin Cermak
Modified: 2017-04-05 10:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
The libatomic library is unavailable for the 64-bit ARM architecture on Red Hat Enterprise Linux versions earlier than Red Hat Enteprise Linux 7.3. As a consequence, the devtoolset-6-libatomic-devel package cannot be installed. In Red Hat Enterprise Linux 7.3, the libatomic package for the 64-bit ARM architecture is shipped in the gcc-libraries package and will be supported when Red Hat Enterprise Linux 7.3 is generally available.
Clone Of: 1362438
Environment:
Last Closed: 2016-10-10 15:51:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Cermak 2016-09-22 07:24:38 UTC
+++ This bug was initially created as a clone of Bug #1362438 +++

Description of problem:

=======
devtoolset-6-gcc contains devtoolset-6-libatomic-devel; it requires libatomic >= 4.8.0 but libatomic seems not being provided on aarch64


Version-Release number of selected component (if applicable):

devtoolset-6-libatomic-devel-0:6.1.1-4.el7.aarch64


Actual results:

Resolving Dependencies
--> Running transaction check
---> Package devtoolset-6-libatomic-devel.aarch64 0:6.1.1-4.el7 will be installed
--> Processing Dependency: libatomic >= 4.8.0 for package: devtoolset-6-libatomic-devel-6.1.1-4.el7.aarch64
--> Finished Dependency Resolution
Error: Package: devtoolset-6-libatomic-devel-6.1.1-4.el7.aarch64 (devtoolset-6.0)
           Requires: libatomic >= 4.8.0
=======


Although this has been fixed for rhel-7.3, it is still an issue for rhel-7.2.  On rhel-7.3 this has been fixed and the fix verified.  I propose to document it as known issue and close, because this is the first time we're shipping DTS on aarch64 and I doubt any customer will need it on RHEL-7.2(.z).  But OTOH, if others consider this an issue, please, raise the priority.  Thanks.

Comment 4 Martin Cermak 2017-04-05 06:00:36 UTC
This has been documented as a Known issue.


Note You need to log in before you can comment on or make changes to this bug.