Bug 137854 - Japanese document from Windows is heavily broken
Japanese document from Windows is heavily broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-02 03:44 EST by Nakai
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 03:32:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A sample document, Red Hat Japan press release is pasted. (28.00 KB, application/octet-stream)
2004-11-02 03:45 EST, Nakai
no flags Details
Is this any better? It should be using Kochi Gothic now... (112.42 KB, image/png)
2004-11-02 13:17 EST, Dan Williams
no flags Details
an expected screenshot with Kochi Gothic (91.56 KB, image/png)
2004-11-02 13:38 EST, Akira TAGOH
no flags Details
screenshot with OOo-1.1.2-17.6.EL4 (43.19 KB, image/png)
2004-12-10 12:38 EST, Akira TAGOH
no flags Details
Screenshot from fresh 2004-12-10 RHEL4 Desktop install with ttfonts-ja and OOo 1.1.2-17.6.EL4 (110.78 KB, image/png)
2004-12-10 12:51 EST, Dan Williams
no flags Details

  None (edit)
Description Nakai 2004-11-02 03:44:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Font aliasing of openoffice.org is crazy and
documents are broken.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Write doc on MS Office
2. Put it on FC3T3
3. Open it with ooffice
    

Actual Results:  Crazy Japanese.
Full-width hyphen is missing on display.
Some Japanese text are partialy missing on display.
Japanese punctuation marks shows up vertical writing glpyhs.

Expected Results:  Sane Japanese

Additional info:

Select all documents and set font to 'Kochi Gothic'
and you can see the correct glyphs, except texts in image objects.

I don't think it's normal severity.
Comment 1 Nakai 2004-11-02 03:45:22 EST
Created attachment 106062 [details]
A sample document, Red Hat Japan press release is pasted.
Comment 2 Dan Williams 2004-11-02 13:17:46 EST
Created attachment 106079 [details]
Is this any better?  It should be using Kochi Gothic now...
Comment 3 Akira TAGOH 2004-11-02 13:38:31 EST
Created attachment 106081 [details]
an expected screenshot with Kochi Gothic

I just did select all and changed the font for those to Kochi Gothic.
Comment 4 Dan Williams 2004-11-02 13:45:10 EST
Fix will be in 1.1.2-11
Comment 5 Nakai 2004-11-06 10:37:11 EST
Comment #2:
Yes, it seems to work.
Comment 6 Dan Williams 2004-11-11 09:21:46 EST
Great! Closing.
Comment 7 Akira TAGOH 2004-12-10 12:38:10 EST
Created attachment 108332 [details]
screenshot with OOo-1.1.2-17.6.EL4

Reopened. I tested OOo-1.1.2-17.6.EL4. and it breaks this fix again.
Comment 8 Dan Williams 2004-12-10 12:51:36 EST
Created attachment 108333 [details]
Screenshot from fresh 2004-12-10 RHEL4 Desktop install with ttfonts-ja and OOo 1.1.2-17.6.EL4
Comment 9 Dan Williams 2004-12-10 13:38:06 EST
Ok, regression is observed when ttfonts-zh_CN is installed and doc is
viewed.
Comment 10 Dan Williams 2004-12-10 17:03:14 EST
Ok, the real issue here is that OOo is not recognizing the Kochi fonts
(either Gothic or Mincho) as Japanese-enabled fonts, however since the
zh_CN/zh_TW and Korean fonts have localized font names, OOo is able to
detect that and prefers them to the non-localized "kochi" names.  I'll
have to look into how to detect coverage ranges from the font itself,
but I don't think this can get done for RHEL4 GA.
Comment 12 Dan Williams 2004-12-12 14:23:41 EST
I lied, a fix will be in 1.1.2-18.
Comment 13 Dan Williams 2004-12-15 09:29:12 EST
1.1.2-18.6.EL4 is in dist-4E
Comment 14 Lawrence Lim 2005-02-21 02:17:26 EST
Tested with 1.1.2-18.6.EL4, the attached document does not seems to be
broken anymore. However, the font chosen for the display is not Kochi
Gothic but MS font. 

Should it be using the Kochi Gothic font? Is this the acceptable
behaviour? 
Comment 15 Akira TAGOH 2005-02-21 23:58:04 EST
Yes, because it's an original font name which was used in the
document. and OOo just use the Kochi font for the alternative font.
Comment 16 Akira TAGOH 2005-02-23 03:32:41 EST
Closing.

Note You need to log in before you can comment on or make changes to this bug.