Bug 137868 - AltGr aborts search with Ctrl-S
AltGr aborts search with Ctrl-S
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 139424 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-02 08:46 EST by Thomas Woerner
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 21.3-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-13 11:00:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Woerner 2004-11-02 08:46:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041016
Firefox/0.10.1

Description of problem:
Searching of a string which contains e.g. a "[" or similar is not
possible with a german keyboard. The search command is aborted as soon
as AltGr is pressed. 

AltGr is necessary for some characters on german keyboards: @, �, {,
}, [, ], \, �, ~, |, ..


This is also an issue for RHEL-4.

Version-Release number of selected component (if applicable):
emacs-21.3-17

How reproducible:
Always

Steps to Reproduce:
1. Start emacs
2. Enter search string and press AltGr
3.
    

Actual Results:  Search aborts completely.

Expected Results:  Search string contains one of the above charaters.

Additional info:
Comment 1 Jens Petersen 2004-11-02 09:01:49 EST
What is AltGr bound to in X for you?

You say this is new in fc3?
Looking through the changelog entries since fc2, I don't see anything
that could have caused this directly.  Could it be related to some
change in xorg-x11?
Comment 2 Thomas Woerner 2004-11-02 09:24:13 EST
Search is working for me on another box with emacs-21.3-14 and AltGr. 
After upgrading to 21.3-17 it is not working anymore.
Comment 3 Jens Petersen 2004-11-02 09:33:42 EST
You can reproduce with "emacs -q --no-site-file"?
Comment 4 Thomas Woerner 2004-11-02 09:48:34 EST
Yes I can. It is still not working.

"emacs -nw" is not affected.
Comment 5 Jens Petersen 2004-11-03 01:25:32 EST
What is AltGr bound to in X for you?
Comment 6 Thomas Woerner 2004-11-11 09:14:35 EST
xev reports this for AltGr:

KeyPress event, serial 30, synthetic NO, window 0x1800001,
    root 0xb6, subw 0x0, time 2515848786, (114,65), root:(117,841),
    state 0x0, keycode 113 (keysym 0xfe03, ISO_Level3_Shift),
same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x1800001,
    root 0xb6, subw 0x0, time 2515849026, (114,65), root:(117,841),
    state 0x80, keycode 113 (keysym 0xfe03, ISO_Level3_Shift),
same_screen YES,
    XLookupString gives 0 bytes: 
Comment 7 Jens Petersen 2005-01-11 01:49:34 EST
Hmm, I see no changes in the changelog between -14 and -17 that could
affect this.  You don't think it is related to xorg-x11?

Actually I just tried this with a RHEL4 beta and it seems to work fine
for me.  You can reproduce on a clean FC3 install?
Comment 8 Jens Petersen 2005-01-11 01:55:52 EST
Btw a similar bug has been reported for xemacs: bug 144601.
Comment 9 Thomas Woerner 2005-01-11 05:55:17 EST
I have recompiled emacs-21.3-14. This version has the same porblem as
emacs-21.3-17, but the original binary package emacs-21.3-14 does not
have the problem.
Comment 10 Jens Petersen 2005-01-11 06:12:56 EST
Very strange... compiling on fc2 makes it work normally?
Comment 11 Thomas Woerner 2005-01-11 06:28:51 EST
Here is the patch:

http://lists.gnu.org/archive/html/bug-gnu-emacs/2004-10/msg00150.html

It is working for me.
Comment 12 Jens Petersen 2005-01-14 01:15:52 EST
Thanks.

However I'm having problems reproducing this now:

1) I install a fresh fc3 Personal Desktop
2) log into gnome after firstboot,
3) $ setxkbmap de
   $ emacs
4) press AltGr-8

and "[" appears without problem for me.

What am I missing?  (I don't doubt that there is a problem,
but since I can't reproduce it is hard to test the fix...:)
Comment 13 Ville Skyttä 2005-01-14 01:58:08 EST
The problem occurs only with I-search.

Fire up emacs, hit Ctrl-S, then AltGr (no need to press anything
else).  Pressing AltGr terminates the search, so one cannot search for
something  that has eg. "[" in it.
Comment 14 Thomas Woerner 2005-01-14 08:19:20 EST
Please have a look at the summary: "AltGr aborts search with Ctrl-S" ...
Comment 15 Jens Petersen 2005-01-14 08:53:47 EST
Yes, thank you.  I just wanted to make sure this hasn't
been fixed in newer xorg-x11, but it seems not for fc3 yet at least.
And emacs doesn't build currently in devel...
Comment 16 Jens Petersen 2005-01-20 19:52:50 EST
emacs-21.3-20 in rawhide should have the above fix.
Could you please test that first?  Thanks.
Comment 17 Tim Niemueller 2005-01-24 08:41:15 EST
The problem is fixed in rawhide emacs, but xemacs still has the problem.

# rpm -q emacs xemacs
emacs-21.3-20
xemacs-21.4.16-1
Comment 18 Thomas Woerner 2005-01-24 11:47:15 EST
emacs-21.3-20 works for me.
Comment 19 Ville Skyttä 2005-01-24 17:37:05 EST
For XEmacs, see bug 144601; it includes an attached fix that has already been
applied upstream.
Comment 20 Jens Petersen 2005-01-24 19:23:42 EST
Thanks.
Comment 21 Jens Petersen 2005-01-24 19:24:25 EST
Re-opening for FC3 update.
Comment 22 Jens Petersen 2005-02-13 11:00:37 EST
Fixed in recent movemail security update.
Comment 23 Jens Petersen 2005-02-14 00:19:53 EST
*** Bug 139424 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.