Bug 137939 - dhcpd doesn't bind to interfaces specified on command line
dhcpd doesn't bind to interfaces specified on command line
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-02 17:30 EST by Albert Strasheim
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 12:16:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2004-11-02 17:30:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3)
Gecko/20040911 Firefox/0.10

Description of problem:
According to the dhcpd man page, listing interfaces in the command
line arguments of dhcpd should make dhcpd only bind to those interfaces.

However, specifying an interface in /etc/sysconfig/dhcpd in the
DHCPDARGS variable doesn't have this behaviour. According to netstat,
dhcpd still listens on all interfaces.

Version-Release number of selected component (if applicable):
dhcp-3.0.1rc14-1

How reproducible:
Always

Steps to Reproduce:
1. Start dhcpd with specific interface in DHCPDARGS
2. netstat -na 
    

Actual Results:  dhcpd listens on all interfaces

Expected Results:  dhcpd should listen on specified interface

Additional info:

The workaround is to specify a local-address in /etc/dhcpd.conf

http://lists.freebsd.org/pipermail/freebsd-questions/2004-May/045675.html
http://www.monkey.org/openbsd/archive/bugs/0009/msg00044.html
http://www.redhat.com/archives/redhat-list/2002-February/msg00725.html
http://albert.bagasie.com/archives/000032.html
Comment 1 Jason Vas Dias 2004-11-03 12:16:24 EST
 While dhcpd "listens" to the "ANY ADDRESS" (0.0.0.0:67), and so will
 receive packets on all interfaces, it only responds to packets 
 from subnets that match a subnet declaration, or which match
 the subnet of the interface given on the command line. 
 Because dhcp will not allow more than one instance of the dhcpd 
 process to run, this should not be a problem (you are never able
 to run more than one dhcpd process, so why do you need it to bind 
 to only one address with port 67?) . In case you do, you have found
 the workaround: set the local-address option in dhcpd.conf .
 So I don't agree this is a bug. We should not make the Red Hat DHCP
 server have seriously divergent behaviour to the ISC DHCP server.
 If you disagree, please send your new feature request to :
 dhcp-server@isc.org - if ISC choose to implement this differently
 in new releases, we'll pick it up. 
 By the way, you can download the latest release of DHCP (3.0.1-11)
 for FC2 from:  http://people.redhat.com/~jvdias/DHCP/FC2 
 I am in the process of getting this pushed to FC2 updates.

Note You need to log in before you can comment on or make changes to this bug.