Bug 137947 - kde-i18n packages does not install when using system-config-packages
kde-i18n packages does not install when using system-config-packages
Status: CLOSED DUPLICATE of bug 188355
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: i18n
Depends On:
  Show dependency treegraph
Reported: 2004-11-02 20:35 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-21 21:19:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2004-11-02 20:35:49 EST
Description of problem:
After a fresh install of RHEL4-Beta2-RC1027.0 in a non-en_US locale, I
used system-config-packges to install KDE desktop. However, using this
option, the language pack (kde-i18n) does not get install and is not
able to be selected.

Is it possible if we can have the following language pack included in
comps as these are locales offically supported by RHEL4.


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install KDE desktop using system-config-packages after install
Actual results:

Expected results:

Additional info:
Tried both NoVariant and AS
Comment 1 Leon Ho 2004-11-05 21:37:53 EST
Is it a post installation right? They are in comps, but just
s-c-packages does not pick it up because it does not reference
supported languages? Moving component to system-config-packages.
Comment 3 Jeremy Katz 2004-11-08 09:51:47 EST
This is due to the fact that the handling of all of the kde-i18n stuff
is a *massive* hack to work around the fact that kde isn't a sane
project with translations included with the code.

anaconda has some hacky stuff to go in and cause the (optional)
kdelibs-i18n stuff to be selected when you have the right set of
languages and the packages in the requires tags selected.  But I
really don't want to push that further (for one thing, it's extremely
Comment 6 Jay Turner 2004-11-09 04:07:52 EST
I agree that given the circumstances, this isn't a blocker to the RC.  We will
need to get something into the GSS team so they know what's going on and can
assist folks experiencing problems.  This actually sounds like more of a KDE bug
than anything, but just going to leave this bug as it is and remove it from the
blocker list . . . which actually appears to have occurred already.
Comment 7 Jeremy Katz 2004-11-09 09:36:49 EST
And it's not a change in behavior from any previous release either.
Comment 10 John Thacker 2006-04-21 21:19:03 EDT
So this problem is pirut's now.  There's already a duplicate bug there for this
behavior, Behavior 188355.

*** This bug has been marked as a duplicate of 188355 ***

Note You need to log in before you can comment on or make changes to this bug.