Bug 13795 - Soundblaster Live! detected but errored out
Summary: Soundblaster Live! detected but errored out
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 14057 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-12 14:25 UTC by Mick Tantasirikorn
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-26 03:54:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mick Tantasirikorn 2000-07-12 14:25:49 UTC
I have a soundblaster live in a Dell Precision 220, 420 and 620.  I ran 
sound config and received errors.  below is the sndconfig error as well as 
the lspci -v output.  Since this happes on three different systems with 
different processor, memory, HD, and videocard, I think it is independent 
of configuration.

error from sndconfig

The following error occurred running the modprobe       #   
           program:                                                    
                                                                       
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: unresolved         
           symbol remap_page_range                                     
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: unresolved         
           symbol __wake_up                                            
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: unresolved         
           symbol kmalloc                                              
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: unresolved         
           symbol interruptible_sleep_on                               
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: unresolved  
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: unresolved         
           symbol __pollwait                                           
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: unresolved         
           symbol kfree                                                
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: unresolved         
           symbol mem_map                                              
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: unresolved         
           symbol printk                                               
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: insmod             
           /lib/modules/2.2.16-8smp/misc/emu10k1.o failed              
           /lib/modules/2.2.16-8smp/misc/emu10k1.o: insmod             
           sound-slot-0 failed                                     #   
                                                                      
-----
lspci -v output

00:00.0 Host bridge: Intel Corporation 82840 840 (Carmel) Chipset Host 
Bridge (Hub A) (rev 01)
	Subsystem: Dell Computer Corporation: Unknown device 0097
	Flags: bus master, fast devsel, latency 0
	Memory at f0000000 (32-bit, prefetchable)
	Capabilities: [a0] AGP version 2.0

00:01.0 PCI bridge: Intel Corporation 82840 840 (Carmel) Chipset AGP 
Bridge (rev 01) (prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, fast devsel, latency 64
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
	Memory behind bridge: fc000000-fdffffff
	Prefetchable memory behind bridge: e0000000-efffffff

00:02.0 PCI bridge: Intel Corporation 82840 840 (Carmel) Chipset PCI 
Bridge (Hub B) (rev 01) (prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, fast devsel, latency 64
	Bus: primary=00, secondary=02, subordinate=03, sec-latency=64
	Memory behind bridge: fb000000-fbffffff
	Prefetchable memory behind bridge: f6000000-f6ffffff

00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02) (prog-if 
00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=04, subordinate=04, sec-latency=64
	I/O behind bridge: 0000e000-0000efff
	Memory behind bridge: f9000000-faffffff
	Prefetchable memory behind bridge: f5000000-f5ffffff

00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
	Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation 82801AA IDE (rev 02) (prog-if 80 
[Master])
	Subsystem: Intel Corporation 82801AA IDE
	Flags: bus master, medium devsel, latency 0
	I/O ports at ffa0

00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02) (prog-if 00 
[UHCI])
	Subsystem: Intel Corporation 82801AA USB
	Flags: bus master, medium devsel, latency 0, IRQ 19
	I/O ports at ff80

00:1f.3 SMBus: Intel Corporation 82801AA SMBus (rev 02)
	Subsystem: Intel Corporation 82801AA SMBus
	Flags: medium devsel, IRQ 17
	I/O ports at dcd0

01:00.0 VGA compatible controller: nVidia Corporation GeForce 256 (rev 10) 
(prog-if 00 [VGA])
	Subsystem: Elsa AG: Unknown device 0c48
	Flags: 66Mhz, medium devsel, IRQ 16
	Memory at fc000000 (32-bit, non-prefetchable)
	Memory at e8000000 (32-bit, prefetchable)
	Expansion ROM at 80000000 [disabled]
	Capabilities: [60] Power Management version 1
	Capabilities: [44] AGP version 2.0

02:1f.0 PCI bridge: Intel Corporation 82806AA PCI64 Hub PCI Bridge (rev 
02) (prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, fast devsel, latency 0
	Bus: primary=02, secondary=03, subordinate=03, sec-latency=64

03:00.0 PIC: Intel Corporation 82806AA PCI64 Hub Advanced Programmable 
Interrupt Controller (rev 01) (prog-if 20 [IO(X)-APIC])
	Subsystem: Intel Corporation 82806AA PCI64 Hub Advanced 
Programmable Interrupt Controller
	Flags: fast devsel

04:05.0 SCSI storage controller: Adaptec 7899P (rev 01)
	Subsystem: Dell Computer Corporation: Unknown device 0097
	Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 17
	BIST result: 00
	I/O ports at ec00
	Memory at f9fff000 (64-bit, non-prefetchable)
	Expansion ROM at fa000000 [disabled]
	Capabilities: [dc] Power Management version 2

04:05.1 SCSI storage controller: Adaptec 7899P (rev 01)
	Subsystem: Dell Computer Corporation: Unknown device 0097
	Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 18
	BIST result: 00
	I/O ports at e800
	Memory at f9ffe000 (64-bit, non-prefetchable)
	Expansion ROM at fa000000 [disabled]
	Capabilities: [dc] Power Management version 2

04:07.0 Ethernet controller: 3Com Corporation 3c905C-TX [Fast Etherlink] 
(rev 78)
	Subsystem: Dell Computer Corporation: Unknown device 0097
	Flags: bus master, medium devsel, latency 64, IRQ 19
	I/O ports at e480
	Memory at f9ffdc00 (32-bit, non-prefetchable)
	Expansion ROM at fa000000 [disabled]
	Capabilities: [dc] Power Management version 2

04:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10000 (rev 
07)
	Subsystem: Creative Labs CT4780 SBLive! Value
	Flags: bus master, medium devsel, latency 64, IRQ 18
	I/O ports at e460
	Capabilities: [dc] Power Management version 1

04:0a.1 Input device controller: Creative Labs SB Live! (rev 07)
	Subsystem: Creative Labs Gameport Joystick
	Flags: bus master, medium devsel, latency 64
	I/O ports at e458
	Capabilities: [dc] Power Management version 1

Comment 1 Bill Nottingham 2000-07-12 16:16:31 UTC
This is a problem with the kernel build, not with sndconfig (unresolved
symbols). Reassigning to the kernel.

Comment 2 Brock Organ 2000-07-18 15:26:48 UTC
*** Bug 14057 has been marked as a duplicate of this bug. ***

Comment 3 Matt Wilson 2000-07-26 03:54:04 UTC
should be fixed in beta5, please verify.



Note You need to log in before you can comment on or make changes to this bug.