Bug 137952 - udev doesn't create generic SCSI device
udev doesn't create generic SCSI device
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-02 22:40 EST by Jonathan Kamens
Modified: 2014-03-16 22:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 22:41:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2004-11-02 22:40:42 EST
I have a SCSI scanner.  Kernel 2.4.x recognizes it as /dev/sg0. 
Current udev doesn't create /dev/sg*, or apparently any other devices
pointing at this device, on boot.  I had to create it with "MAKEDEV
sg" to be able to use my scanner.
Comment 1 Harald Hoyer 2004-11-03 05:13:50 EST
which version of udev?
# modprobe sg
and all sg device nodes should be created...
Comment 2 Jonathan Kamens 2004-11-03 11:13:28 EST
udev-039-6
modprobe sg worked.
But it's not obvious to me why I should have to probe for a module to 
get able to use this device.  Will configuring it with kudzu get it 
to load automatically on reboot?
Comment 3 Harald Hoyer 2004-11-03 12:59:34 EST
could you please give me the output of:
# find /sys/devices -name type 
# find /sys/devices -name type | xargs cat
Comment 4 Jonathan Kamens 2004-11-03 13:35:45 EST
jik:~!1016$ sudo find /sys/devices -name type
Password:
/sys/devices/pci0000:00/0000:00:0e.0/host0/0:0:4:0/type
jik:~!1017$ sudo find /sys/devices -name type | xargs cat
6
jik:~!1018$ mount | grep -i sysfs
Comment 5 Harald Hoyer 2004-11-04 08:29:05 EST
$ rpm -qf /etc/hotplug/scsi.agent
hotplug-2004_04_01-6

in scsi.agent, modules sg should be loaded on TYPE=6
Comment 6 Harald Hoyer 2004-11-04 08:29:36 EST
and maybe on some other types, too
Comment 7 Bill Nottingham 2004-11-04 16:04:24 EST
Fixed in -8.
Comment 8 Moritz Barsnick 2004-11-11 12:31:13 EST
FYI: In udev's changelog, this bug is wrongly referenced as bug 
#137592.
Comment 9 Trond Eivind Glomsrød 2004-12-14 10:24:12 EST
A problem with the latest errata one as well, with scsi tape changers.
TYPE=8
Comment 10 Bill Nottingham 2004-12-14 11:50:08 EST
+    8)         TYPE=changer ; MOUDLE=sg ;;

is in the patch ... is this in your scsi.agent?
Comment 11 Matthew Richardson 2005-03-21 14:03:29 EST
I have this same problem. Bru Server backup software cannot find a tape drive
unless I run "modprobe sg" after boot.

[root]# find /sys/devices -name type
/sys/devices/pci0000:00/0000:00:1e.0/0000:02:0b.0/host0/target0:0:0/0:0:0:0/type

[root]# find /sys/devices -name type | xargs cat
1
Comment 12 Bill Nottingham 2005-03-22 22:41:04 EST
Check for a MODULE typo in /etc/hotplug/scsi.agent - this should be fixed in
2004_09_23-3.

Note You need to log in before you can comment on or make changes to this bug.