Bug 137976 - Hangup after installation due to failed monitor detection
Hangup after installation due to failed monitor detection
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-03 10:51 EST by Philippe Rigault
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 10:38:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Rigault 2004-11-03 10:51:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
Tested on FC3-RC5 (FC3 test3, kernel 2.6.9-1.649)

The popular (and awesome) Samsung Syncmaster 213T (21" 1600x1200 LCD) fails to be detected during install.
FWIW, I am using the DVI input of the monitor (it has digital and analog input) on an Sun W1100z with NVIDIA Quadro4 NVS (nv driver).

What is really bad is that the default configuration by anaconda results in a hangup at boot time.
Since the system cannot boot, it cannot run firstboot and configure manually the monitor, and it cannot even allow the user to boot in text mode to fix the monitor settings by hand.

The only solution to get a bootable system is to boot from CD with 'linux rescue', and set the default init level to 3 (in /etc/inittab). After that, the system boots in text mode (asking firstboot-like questions in text mode) and all is well, including the ability to start X (in 800x600 mode by default) and run system-config-display.

I have had this problem since FC2.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC3 on system with Samsung 213T monitor
2. Install warns "unknown monitor", but goes fine until completion
3. Reboot system after install
    

Actual Results:  Hangup on boot. Does not run firstboot. Cannot exit in text mode.

Expected Results:  Ideally, monitor detected, configured, all is well.
Minimally, either firsboot should proceed, or fallback in text mode.

Additional info:

The settings for the Samsung Syncmaster 191TFT are working fine on the 213T.

 HorizSync   30.0 - 81.0
 VertRefresh 56.0 - 85.0
Comment 1 Philippe Rigault 2004-11-09 10:38:08 EST
I cannot reproduce the hangup on an install with FC3 final, so I 
close it. 
 
The SyncMaster 213T is still not detected during install, but 
firstboot proceeds O.K, so I can manually select 'Syncmaster 
191TFT' (closest monitor) and X starts fine thereafter. 
 
 

Note You need to log in before you can comment on or make changes to this bug.