Bug 137994 - Suported burn-modes only as root
Suported burn-modes only as root
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-03 12:47 EST by Quereller
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 16:28:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quereller 2004-11-03 12:47:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922 Epiphany/1.2.7

Description of problem:
as user:
Supported modes:
cdrecord: Drive does not support TAO recording.

as root:
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R



Version-Release number of selected component (if applicable):
cdrecord-2.01.1-0.FC2.1

How reproducible:
Always

Steps to Reproduce:
1. Buy a Plextor PX-708A
2. Try to burn a image as user

    

Actual Results:  Can't burn

Expected Results:  Should burn

Additional info:

[user@rechner user]$ cdrecord dev=/dev/hdc boot.iso
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'DVDR   PX-708A  '
Revision       : '1.04'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes:
cdrecord: Drive does not support TAO recording.
cdrecord: Illegal write mode for this drive.


[root@rechner user]# cdrecord dev=/dev/hdc boot.iso
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'DVDR   PX-708A  '
Revision       : '1.04'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE VARIREC FORCESPEED
SINGLESESSION HIDECDR
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R
Speed set to 7056 KB/s
Starting to write CD/DVD at speed  40.0 in real TAO mode for single
session.
Last chance to quit, starting real write    0 seconds. Operation starts.
trackno=0
Track 01: Total bytes read/written: 8404992/8404992 (4104 sectors).



P.S. I'm not sure if this is actually a bug, I'm sorry if not.
Comment 1 Jan "Yenya" Kasprzak 2004-11-03 16:49:06 EST
I can reproduce this problem on my FC2 box.

CD-writer is "L-DT-ST RW/DVD GCC-4320B" (from hdparm -i /dev/hdc),
cdrecord-2.01.1-0.FC2.1, kernel 2.6.9 vanilla (I may try the FC2 kernel
as well if anyone wants).

According to strace, cdrecord cannot send ATAPI ioctl to the drive,
even though the device is opened for O_RDWR:
[...]
open("/dev/cdrom", O_RDWR|O_NONBLOCK|O_EXCL) = 3
[...]
ioctl(3, CDROM_SEND_PACKET, 0xbfffd040) = -1 EIO (Input/output error)
[...]
As root, everything works as expected.
Comment 2 Harald Hoyer 2004-11-04 05:46:21 EST
and hdc is owned by you and not by root or someone else??
Comment 3 Harald Hoyer 2004-11-04 09:50:11 EST
Quereller, what kernel version do you have?
Comment 4 Quereller 2004-11-04 16:27:32 EST
The dev file:
brw-------  1 user disk 22, 0 23. Feb 2004  /dev/hdc

The kernel:
kernel-smp-2.6.8-1.521 and also kernel-2.6.8-1.521

but I anyway its fixed in rawhide with kernel-smp-2.6.9-1.667

Thank you for your help!

Note You need to log in before you can comment on or make changes to this bug.