Bug 138026 - Dell GX280 Video Card (915G) unsupported
Summary: Dell GX280 Video Card (915G) unsupported
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: dff
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-03 22:03 UTC by Greg Marsden
Modified: 2007-11-30 22:07 UTC (History)
7 users (show)

Fixed In Version: RHEL4 U2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-24 10:59:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg Marsden 2004-11-03 22:03:15 UTC
Comes up as Unknown Device 0179

Linux ap652tst 2.4.21-21.ELsmp #1 SMP Fri Oct 1 09:28:06 EDT 2004 i686
i686 i386 GNU/Linux

lspci -vv

00:02.0 VGA compatible controller: Intel Corp. 82915G Express Chipset
Family
Graphics Controller (rev 04) (prog-if 00 [VGA])
        Subsystem: Dell: Unknown device 0179
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort-
<MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at dff00000 (32-bit, non-prefetchable)
[size=512K]
        Region 1: I/O ports at e898 [size=8]
        Region 2: Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Region 3: Memory at dfec0000 (32-bit, non-prefetchable)
[size=256K]
        Capabilities: [d0] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:02.1 Display controller: Intel Corp. 82915G Express Chipset Family
Graphics
Controller (rev 04)
        Subsystem: Dell: Unknown device 0179
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort-
<MAbort- >SERR- <PERR-
        Latency: 0
        Region 0: Memory at dff80000 (32-bit, non-prefetchable)
[size=512K]
        Capabilities: [d0] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Could be as simple as adding pci id... please advise.

Comment 1 Arjan van de Ven 2004-11-04 07:45:38 UTC
it's not a pci id; it's a whole new set of drivers
(kernel: AGP and DRM, XFree)


Comment 2 Greg Marsden 2004-11-04 18:25:00 UTC
Unfortunately it's what Dell is shipping as the new standard desktop

Comment 3 Suzanne Hillman 2004-11-08 17:25:45 UTC
Internal RFE bug #138374 entered; will be considered for future releases.

Comment 6 Ernie Petrides 2005-09-13 03:52:20 UTC
Hi, Greg.  Does this bug report need to be Oracle-confidential?  If not,
please uncheck the "Oracle Confidential Group" box near the bottom.  If
so, just let me know so that I can add the appropriate Red Hat groups.

Thanks in advance.  -ernie


Comment 7 Greg Marsden 2005-09-13 22:27:07 UTC
this bug is old!

Comment 8 Mike A. Harris 2005-09-24 10:59:21 UTC
Intel i915 hardware is supported in Red Hat Enterprise Linux 4, and additional
support for newer Intel i915/i945 hardware has been added to RHEL4 U2.

Unfortunately, Red Hat Enterprise Linux version 3 does not contain the
necessary core X server infrastructure to accomodate the driver source
code being used in RHEL4.  Backporting the X server code, Mesa code,
kernel DRM code, and other required bits from RHEL4 to RHEL3 would be
a significant non-trivial undertaking, which would pose a significant
risk of regression for the X server and other video hardware support
as a whole.

Due to these and other factors, adding native Intel i915/i945 hardware
support to RHEL3 is currently not feasible.

It is recommended to use the "vesa" driver for this hardware on RHEL3
systems, or to upgrade to the latest RHEL4 release.

Setting resolution/status to "CURRENTRELEASE" of RHEL4 U2 for support for
this hardware.

Comment 9 Ernie Petrides 2005-09-26 19:36:42 UTC
Changing disposition to WONTFIX for RHEL3.


Note You need to log in before you can comment on or make changes to this bug.