Bug 138048 - udev doesn't create /dev/cdrom symlinks for IDE, breaks pam_console
Summary: udev doesn't create /dev/cdrom symlinks for IDE, breaks pam_console
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-04 05:01 UTC by Bill Nottingham
Modified: 2014-03-17 02:50 UTC (History)
2 users (show)

Fixed In Version: 039-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 23:49:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2004-11-04 05:01:04 UTC
SSIA.

I believe it's because /bin/cat doesn't exist on the initrd (so the
check of /proc/ide/blah/media doesn't work). But that's just a guess
at this point.

Seemed to start happening with the upgrade from kernel-2.6.9-1.649 to
kernel-2.6.9-1.667, and from udev-039-6 to udev-039-8.FC3.

Comment 1 Bill Nottingham 2004-11-04 05:51:08 UTC
No, the missing 'cat' doesn't appear to be it.

Comment 2 Bill Nottingham 2004-11-04 06:02:37 UTC
Oddly... turning *on* logging in udev.conf fixes it.

Comment 3 Harald Hoyer 2004-11-04 10:43:20 UTC
seems like the /proc file does not exist, if udev is too fast...

Comment 4 Harald Hoyer 2004-11-04 14:21:47 UTC
fixed in udev-039-10.FC3.1


Note You need to log in before you can comment on or make changes to this bug.