Bug 138053 - yum does not work after upgrade from fc2 to fc3
yum does not work after upgrade from fc2 to fc3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 00:54 EST by Leon Ho
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 08:25:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current yum.conf (253 bytes, text/plain)
2004-11-04 00:54 EST, Leon Ho
no flags Details

  None (edit)
Description Leon Ho 2004-11-04 00:54:37 EST
Created attachment 106149 [details]
current yum.conf
Comment 1 Leon Ho 2004-11-04 00:54:37 EST
Description of problem:
yum does not work after upgrade from fc2 to fc3. first it was a problem that it
is using old conf. I tried to replaced with yum.conf.rpmnew and it still does
not work. I have also tried to remove all the /var/cache/yum/* and it is still
the same. Error message is:
[root@windcloud ~]# yum update
Setting up Update Process
Setting up Repo:  base
Cannot find a valid baseurl for repo: base


Version-Release number of selected component (if applicable):
2.1.11-3

Steps to Reproduce:
1. upgrade from fc2 -> fc3
2. yum update
  
Actual results:
[root@windcloud ~]# yum update
Setting up Update Process
Setting up Repo:  base
Cannot find a valid baseurl for repo: base


Expected results:
should at least pass this.

Additional info:
Not sure if it is related to old config or not? but i have tried to see from
strace and see what file (conf etc) it trying to open but nothing obvious. or is
it because there aren't any repo yet?
Comment 2 Seth Vidal 2004-11-04 01:01:57 EST
if you look in /etc/yum.repos.d
and you look for a repository in one of the .repo files in there named
[base] you should see that there is either a mirrorlist or a baseurl
in there.

See if either of the urls mentioned exist.

Comment 3 Leon Ho 2004-11-04 01:22:42 EST
Okay it is as I guess, it does not have fedora-core-3 mirror list yet.

But doesn't it should continue to other repos other than just quit?
Comment 4 Seth Vidal 2004-11-04 08:25:17 EST
No, The condition where a repository configuration is damaged and not
functional is an error condition. It exits.

You should be able to run:
yum --disablerepo=base [normal command]

to get around it.

Note You need to log in before you can comment on or make changes to this bug.