Bug 138059 - "trap(bash built-in commands)" cannot run properly.
"trap(bash built-in commands)" cannot run properly.
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bash (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 04:47 EST by L3support
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 11:39:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-11-04 04:47:31 EST
Description of problem:

"trap" cannot run properly 
when we run our test program calling "trap" on RHEL4
(Please refer to the following "Steps to Reproduce" for the test program.)

Following messages are shown when we run the test programe on RHEL4.

trap: usage: trap [-lp] [arg|-] [signal_spec ...]

The result which run the test program on RHEL3 is as follows.

Done.


Isn't there the compatibility of "trap" between RHEL4 and RHEL3 ?

Version-Release number of selected component (if applicable):

How reproducible:
always

Steps to Reproduce:
1. ./trap_smp.sh
2.

-----
// test program: trap_smp.sh
#!/bin/sh
trap 0
echo Done.
-----
 
Actual results:
trap: usage: trap [-lp] [arg|-] [signal_spec ...]

Expected results:
"trap" can run propely on RHEL4.
Comment 1 Tim Waugh 2004-11-04 04:59:28 EST
This has been fixed since bash-3.0-13.  Please verify that it fixes
the problem for you.
Comment 2 Jay Turner 2004-11-11 11:39:21 EST
Fix confirmed with bash-3.0-17.

Note You need to log in before you can comment on or make changes to this bug.