Bug 138086 - Internal error
Internal error
Status: CLOSED WORKSFORME
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 10:57 EST by David Lawrence
Modified: 2007-04-18 13:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 12:21:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2004-11-04 10:57:01 EST
Description of problem:
I just logged in and the page was reloading from my session that I had
saved when I logged out.


Bugzilla has suffered an internal error. Please save this page and send
it to bugzilla-owner@redhat.com with details of what you were doing at
the time this message appeared.

URL: https://bugzilla.redhat.com/beta2/show_bug.cgi?format=ft&id=131651

undef error - DBD::Pg::st execute failed: ERROR: parser: parse error at
or near "WHERE" at character 454 [for Statement "SELECT DISTINCT
groups.id, name, description, bug_group_map.group_id IS NOT NULL,
user_group_map.group_id IS NOT NULL, isactive, membercontrol,
othercontrol FROM groups LEFT JOIN bug_group_map ON
bug_group_map.group_id = groups.id AND bug_id = 131651 LEFT JOIN
user_group_map ON user_group_map.group_id = groups.id AND user_id = 0
AND isbless = 0 LEFT JOIN group_control_map ON
group_control_map.group_id = groups.id AND group_control_map.product_id
= WHERE isbuggroup = 1"] at Bugzilla/DB.pm line 74 Bugzilla::DB::SendSQL
('SELECT DISTINCT groups.id, name, description, bug_group_map.g...')
called at Bugzilla/Bug.pm line 364 Bugzilla::Bug::groups
('Bugzilla::Bug=HASH(0x9c2c048)') called
at /usr/lib/perl5/site_perl/5.8.0/Template/Stash.pm line 604 eval {...}
called at /usr/lib/perl5/site_perl/5.8.0/Template/Stash.pm line 604
Template::Stash::_dotop('Template::Stash=HASH
(0x99c5444)','Bugzilla::Bug=HASH(0x9c2c048)','groups',0) called
at /usr/lib/perl5/site_perl/5.8.0/Template/Stash.pm line 379
Template::Stash::get('Template::Stash=HASH(0x99c5444)','ARRAY
(0x9a78fcc)') called at
data/template/template/en/default/bug/edit.html.tmpl line 851 eval {...}
called at data/template/template/en/default/bug/edit.html.tmpl line 16
Template::Provider::__ANON__('Template::Context=HASH(0x990c670)') called
at /usr/lib/perl5/site_perl/5.8.0/Template/Document.pm line 144 eval
{...} called at /usr/lib/perl5/site_perl/5.8.0/Template/Document.pm line
142 Template::Document::process('Template::Document=HASH
(0x9a5a914)','Template::Context=HASH(0x990c670)') called
at /usr/lib/perl5/site_perl/5.8.0/Template/Context.pm line 315 eval
{...} called at /usr/lib/perl5/site_perl/5.8.0/Template/Context.pm line
295 Template::Context::process('Template::Context=HASH
(0x990c670)','bug/edit.html.tmpl') called at
data/template/template/en/default/bug/show-ft.html.tmpl line 112 eval
{...} called at data/template/template/en/default/bug/show-ft.html.tmpl
line 16 Template::Provider::__ANON__('Template::Context=HASH
(0x990c670)') called
at /usr/lib/perl5/site_perl/5.8.0/Template/Document.pm line 144 eval
{...} called at /usr/lib/perl5/site_perl/5.8.0/Template/Document.pm line
142 Template::Document::process('Template::Document=HASH
(0x99b6cf4)','Template::Context=HASH(0x990c670)') called
at /usr/lib/perl5/site_perl/5.8.0/Template/Context.pm line 315 eval
{...} called at /usr/lib/perl5/site_perl/5.8.0/Template/Context.pm line
295 Template::Context::process('Template::Context=HASH
(0x990c670)','Template::Document=HASH(0x99b6cf4)') called
at /usr/lib/perl5/site_perl/5.8.0/Template/Service.pm line 90 eval {...}
called at /usr/lib/perl5/site_perl/5.8.0/Template/Service.pm line 88
Template::Service::process('Template::Service=HASH
(0x98b7c5c)','bug/show-ft.html.tmpl','HASH(0x91865f8)') called
at /usr/lib/perl5/site_perl/5.8.0/Template.pm line 59 Template::process
('Bugzilla::Template=HASH(0x91866dc)','bug/show-ft.html.tmpl','HASH
(0x91865f8)') called at /var/www/bugzilla/beta2/show_bug.cgi line 149
Comment 1 Mike MacKenzie 2004-11-11 15:31:20 EST
FYI, This error occurred because, apparently the product_id for the
given bug was blank in the database.
Comment 2 David Lawrence 2004-11-11 15:41:38 EST
Seems to work now. Was the product_id updated manually?
Comment 3 Mike MacKenzie 2004-11-11 17:30:05 EST
I didn't touch it.  It could also have happened if the database was
populated properly, but the Bugzilla::Bug object was not build
properly somehow...
Comment 4 David Lawrence 2004-11-18 12:21:10 EST
Cannot reproduce. Closing and will reopen if still occurs.

Note You need to log in before you can comment on or make changes to this bug.