Bug 138088 - RHEL 2.1U6 beta: fdisk does not list new drive
RHEL 2.1U6 beta: fdisk does not list new drive
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 11:11 EST by Wendy Hung
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 09:16:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/message output after driver modprobe (70.66 KB, text/plain)
2004-11-12 13:40 EST, Wendy Hung
no flags Details
/proc/partitions after the driver is loaded (390 bytes, text/plain)
2004-11-12 13:41 EST, Wendy Hung
no flags Details
strace fdisk -l for the failing case (6.28 KB, text/plain)
2004-11-12 13:42 EST, Wendy Hung
no flags Details
strace fdisk -l after fdisk /dev/sda (7.28 KB, text/plain)
2004-11-12 13:42 EST, Wendy Hung
no flags Details

  None (edit)
Description Wendy Hung 2004-11-04 11:11:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
H010818)

Description of problem:
After installing a new FibreChannel (or ServeRAID) adapter on a x206 
or x306, "fidsk -l" does not list the logical drive as expected.  




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a FibreChannel (or ServeRAID) adapter on a x206 or x306.
2. Reboot system and allow Kudzu to detect the card. 
3. modprobe the qla2300 (or ips) driver 
4. Check dmesg or run fdisk -l to find logical storage.
    

Actual Results:  fdisk -l only lists the onboard ide partition hdc. 



Expected Results:  expected a sda partition listed for the logical 
drive that is attached to the fibre drive.  

Additional info:

However, knowing that /dev/sda is a device, "fdisk /dev/sda" can be 
run successfully.  
Then quit fdisk and rerun "fdisk -l" --> /dev/sda is then listed as 
expected.

This was also seen on 2.1 U5 Gold.
Comment 1 Tom Coughlan 2004-11-06 08:34:25 EST
Please post 

1) the /var/log/message output that occurs when you modprobe the
driver 2) /proc/partitions after the driver is loaded
3) strace fdisk -l for the failing case
4) strace fdisk -l for the care that works (after you do fdisk /dev/sda).

Tom
Comment 2 Wendy Hung 2004-11-12 13:40:18 EST
Created attachment 106594 [details]
 /var/log/message output after driver modprobe
Comment 3 Wendy Hung 2004-11-12 13:41:14 EST
Created attachment 106595 [details]
/proc/partitions after the driver is loaded
Comment 4 Wendy Hung 2004-11-12 13:42:31 EST
Created attachment 106596 [details]
strace fdisk -l for the failing case
Comment 5 Wendy Hung 2004-11-12 13:42:59 EST
Created attachment 106597 [details]
strace fdisk -l after fdisk /dev/sda
Comment 6 Tom Coughlan 2005-09-19 09:16:59 EDT
RHEL 2.1 is no longer receiving routine bug fix updates. Only security and
critical issues are being addressed. Since there is a workaround for this issue,
it does not qualify.  Also, Red Hat recommends the use of parted instead of fdisk. 

Users who have experienced this problem are encouraged to upgrade to the latest
update release, and if this issue is reproducible with parted, please contact
the Red Hat Global Support Services page on our website for technical support
options: https://www.redhat.com/support

If you have a telephone based support contract, you may contact Red Hat at
1-888-GO-REDHAT for technical support for the problem you are experiencing. 


Note You need to log in before you can comment on or make changes to this bug.