Bug 1381262 - texlive-bibtexperllibs-svn40139-3.fc26.noarch: nothing provides perl(BibTeX::Parser)
Summary: texlive-bibtexperllibs-svn40139-3.fc26.noarch: nothing provides perl(BibTeX::...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1381307
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-03 14:11 UTC by Petr Pisar
Modified: 2016-10-28 00:40 UTC (History)
3 users (show)

Fixed In Version: texlive-2016-17.20160520.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-28 00:40:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Pisar 2016-10-03 14:11:41 UTC
texlive-bibtexperllibs-svn40139-3.fc26.noarch cannot be installed be it requires perl(BibTeX::Parser) but no package in Fedora provides it.

The reason is the package installs Perl code the uses BibTeX::Parser module, thus perl-generators will export this dependency into the RPM package. The same package does install the BibTeX::Parser, but not into a standard Perl path, thus the generators does not export the provide symbol into the RPM package.

Solution is to stop requiring perl(*) symbols that comes from your private installation path. I.e. add "%global __requires_exclude_from /usr/share/texlive/texmf-dist/scripts/bibtexperllibs/" into the spec file.

Another solution is package the files into standard Perl path.

Actually the modules have upstream on CPAN <http://search.cpan.org/~borisv/BibTeX-Parser/>, so the best solution is stop bundling them with texlive and package them as a standalone package from CPAN. I can package it for you.

Comment 1 Tom "spot" Callaway 2016-10-03 14:47:09 UTC
Agree that packaging it separately is the cleanest solution, then I can simply empty out that subpackage and have it Require: perl-BibTeX-Parser

Comment 2 Petr Pisar 2016-10-03 16:10:21 UTC
I posted two packages on review. I see you need them in Fedora ≥ 25. Once they arrive to Fedora, you can depend on their modules using "Require: perl(BibTex::Parser)" syntax.

Comment 3 Tom "spot" Callaway 2016-10-03 17:57:44 UTC
I'm going to go ahead and do a new set of texlive builds in f25 and rawhide. When your updates for f25 are done, let me know, and I'll push them into bodhi alongside texlive.

Comment 4 Petr Pisar 2016-10-04 13:18:19 UTC
Both packages are built for F25 and rawhide. I added them into f25-build override. The perl-BibTeX-Parser-0.69-1.fc25 will appear there soon.

Comment 5 Fedora Update System 2016-10-05 20:30:44 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-5.20160520.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50a2bc7997

Comment 6 Fedora Update System 2016-10-06 20:59:43 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-6.20160520.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50a2bc7997

Comment 7 Fedora Update System 2016-10-09 12:30:46 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-7.20160520.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50a2bc7997

Comment 8 Fedora Update System 2016-10-26 20:33:44 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-17.20160520.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50a2bc7997

Comment 9 Fedora Update System 2016-10-28 00:40:43 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-17.20160520.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.